New themes not being added

James Williams 7 years ago updated by Tom 7 years ago 12

I have tried to add a new theme, the user created Modern Theme downloaded from the site. I have extracted the zip to the theme folder but nothing is showing up other than the default theme when i go into change it.

Am i missing a step?

I'm running Ubooquity on a Raspberry Pi with Raspbain in headless mode.

Many Thanks
Under review

the server needs to be restarted for the new theme to appear in the dropdown menu.
You still have only the default theme after restarting ?
Yeah, I've restarted the server, even done a full system reboot and still nothing except the default theme.
Solved it, there is a theme folder in the ubooquity folder as well as one in the home folder (in my case the pi user folder). Put the theme in there and it now works!!
That's strange. Are other Ubboquity files and folders present in your home directory as well ? (cache, logs, preferences.xml...)
If so, this means you have started Ubooquity directly from your home directory (Ubooquity creates files and folders it needs in the "working directory", meaning the directory you are in when you launch it).
If not, there is something I missed.
the only folder that i can see is the themes folder and it's path is /home/pi/themes. Ubooquity is installed in /opt/Uboopuity
I followed this tutorial to install on the raspberry pi http://www.htpcguides.com/install-ubooquity-on-raspberry-pi-for-personal-ebook-server/ (all except the crontab part, i modified that a little as the written one wasn't working for me)

I'm actually having the same problem on a headless ubuntu server. I have placed two different themes in /opt/ubooquity/themes as well as the theme folder in the home directory. I have restarted the server multiple times. I also tried to create a new theme from the admin panel which shows up in the theme selector, but I cannot find the folder it created in either directory. This one has stumped me.
If it appears in theme selectors, it means the new folder exists somewhere on your system.
The somewhere is supposed to be the directory from which you launched Ubooquity, but I assume you have already checked there.

Perhaps you could try to do a "find" on your whole system to locate the newly created directory ? (it has the name you gave to the new theme).

I still have no clue as to why this happens (perhaps some symlink or Linux user right combination I have not anticipated), but knowing where the new dir is created would help.

I found the newly created folder in /root/themes. Even though ubooquity is installed to /opt/ubooquity. I followed the exact same tutorial that James did in case it helps. I added the themes I downloaded to /root/themes and all is well. They worked perfectly.
Interesting, although I still don't understand why the working directory is "/root/".
Do you have other files created by Ubooquity in the "/root/" folder (like "cache", "logs", "preferences.xml"...)?

In any case this problem will be solved by this feature: http://ubooquity.userecho.com/topic/794934-when-using-duserdir-switch-a-few-oddities/.

I do have those files in /root as well as /home/user.
James, Justin, I'm marking this problem as "solved" as you can now explicitely choose the directory where the new theme is created (using the "workdir" option from Ubooquity 1.8.0). But let me know if you still encounter problems with this.