+1

Mac OS X Not Showing Folders

seanpsullivan 3 months ago updated by SRW 2 months ago 2

When I go to “Add Folder” and navigate to my external (HDD) volume it’s blank, no folders show up to share.  Running Big Sur, but this started happening before Big Sur release.

I've got the same problem, I added it to my Big Sur VM and have the same problem on the virtual. 

I suspect this has to do with disk access control. In Big Sur and before (I think it was introduced in Catalina), you have to give explicit access for applications to access files in:

- Desktop folder

- Documents folder

- External drives

- (probably something more that I forget...)

For most apps, this results in a popup window when trying to access such files for the first time, like "Allow <application name> access to folder <foldername> in Desktop?", whereupon you can click to allow or not allow. Your actions here will be visible in System Settings -> Security -> Integrity (guessing exact names, not running macOS in English myself), under "Full disk access" (for apps which can access all files everywhere" or the more specific "Files and folders" (for apps given specific access to specific files), with a checkmark indicating your decision in the popup.

However, it seems as if running Ubooquity does not trigger this popup, and I've not been able to manually add the proper app to the "Full Disk Access" list in system settings. Probably due to this being a Java app and not properly packaged as a "real" mac app -> it's unclear what should actually be added to the list. I tried adding the java executable itself and while it i possible to add, it doesn't help.

So no solution as far as I've been able to find I'm afraid :-(

You can test this no access problem like e.g. trying to add files to Ubooquity in your home directory. If you click in e.g. the folder "Music", you'll see all the files in it, but if you click the folder "Desktop", you'll see nothing. This is because Desktop is as mentioned one of the special folders needing specific access, whereas Music is not.

EDIT: Solution found! :-) Researching some more, what you need to do is to add the following application to the "Full disc access" list in system settings:

/ System/Library/CoreServices/Jar Launcher.app

Then restart Ubooquity, and it should work. Or at least it works for me :-)