+1
Fixed

Comics not fitting to screen

James Williams 5 years ago updated by Tom 4 years ago 20
Hi,

When reading comics in Ubooquity comics only seem to zoom out to only show aboutabout a 1/4 of the size of the comic and I cannot fit the whole comic on the page. Changing the comics cover width and height in settings seems to fix/affect this but it also then changes the spacing of the thumbnails/covers in the library.

Any ideas? is there a setting anywhere to make it auto fit to width or height for reading?
Under review
The comics cover size setting does not have anything to do with the size of the page in the online reader. So I'm surprized modifying on has an impact on the other.

Would you be able to attach a screenshot or two of your problem ? (on which reading device do you have the problem ?)

For now the page is reduced to the width of your screen, but there are no advanced options yet. It's on the todo list.

Here is a screenshot, that's as far as i can zoom out.

I have noticed that it does depend on the size of the comic itself as there are some i have that fit a little better (still not 100% more like 65%)

ps ignore the fact that it says /admin, thats just a result of my dynamic dns setup and not the server.


Could you open this page in the browser you use to read comics and paste the information you got here ?
here's what i get on my phone (galaxy s6).

window.innerWidth : 360
window.innerHeight : 559
window.outerWidth : 360
window.outerHeight : 559
window.devicePixelRatio : 4
navigator.userAgent : Mozilla/5.0 (Linux; Android 5.0.2; SM-G920I Build/LRX22G) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.111 Mobile Safari/537.36
navigator.platform : Linux aarch64
navigator.language : en-GB
screen.availWidth : 360
screen.availHeight : 640
screen.width : 360
screen.height : 640
screen.orientation : [object ScreenOrientation]
And this is what I get on my tablet (galaxy tab s 10.5)

window.innerWidth :980
window.innerHeight :1420
window.outerWidth :800
window.outerHeight :1159
window.devicePixelRatio :2
navigator.userAgent :Mozilla/5.0 (Linux; Android 4.4.2; SM-T800 Build/KOT49H) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.111 Safari/537.36
navigator.platform :Linux armv7l
navigator.language :en-GB
screen.availWidth :800
screen.availHeight :1280
screen.width :800
screen.height :1280
screen.orientation :[object ScreenOrientation]
Thanks. And the problem is the same on both device ?
Yeah, exactally the same on both.
I'm actually having somewhat of the same problem, except it's on my laptop. Having to force zoom out every page (specifically on dual page scans) is kinda hard and annoying to do. Just in case, here's my info:

window.innerWidth :1600
window.innerHeight :744
window.outerWidth :1600
window.outerHeight :872
window.devicePixelRatio :1
navigator.userAgent :Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36
navigator.platform :Win32
navigator.language :en-US
screen.availWidth :1600
screen.availHeight :872
screen.width :1600
screen.height :900
screen.orientation :[object ScreenOrientation]
Dual pages currently have no special treatment. So for them the display problem is more a lack of feature than a bug.

I'll resume investigating the problem asap, but I have planned to rewrite the online reader from scratch anyway.
So there will be a solution, either with a quick bug fix or (perhaps more likely) when the new online reader is ready.
Update on this issue for me. It would seem that for me the issue is determined by the size of the comics. I have a few older comic scans that are lower resolution/size that fit perfectly. Not sure if that's any help.
+2
Just so you know, I have not forgotten this issue. I just chose to rewrite the online reader from scratch to manage user defined sizing and double page auto-split. Work in progres...
Thank you Tom, this is my most anticipated feature!
Just started using Ubooquity. Affects me as well on all devices, regardless of the size, DPI, etc. On PC you can just adjust zoom out but on my mobile devices I can zoom in, but not out. Looking forward to the reader rewrite.
Since the rewrite is going to take some time, here is a workaround:

  1. Create a new theme (or use an existing one, as long as you can edit the pagereader.css file).
  2. Edit the pagereader.css file of the theme you are using and add the following section at the end of the file:
    #displayedpage{
       width:100%
    }    
  3. Restart Ubooquity after having checked you are using the theme you just modified.
After this, your pages should always use 100% of the width of your screen, no more, no less.

I have not tested it on mobile devices though (lack of time), so let me know if you encounter problems applying this workaround.
(or if it works for you, interesting to know too :))
Try UltimateBrowserProject for Android. Scales perfectly on my LGPad 8.3 and Galaxy S6 Edge - I did not have the same experience with Google Chrome, which is my go-to browser on all platforms.
Just out of curiostiy, could we edit the pagereader.css with
#displayedpage{   
     height:100%
}
To fit the comics to the browser height? Having to zoom out to read the books and then zooming back in to view the library all the time on my large screens is kind of tedious.
I have not tried but I doubt it. CSS height management is much trickier than it is for width.
The goos news is that the new comic reader is almost complete and will be part of the next version.
It features "fit to width" and "fit to height" options (as well as an automatic split of double pages).
Awesome. Can't wait for it! That'll be much much nicer. I've taken to just downloading them rather than viewing them in the Web due to this. This will be a welcome change.