0
Not a bug

Ubooquity sometimes rescans entire library

faceless-user 5 years ago updated by Tom 5 years ago 7
I'm not really sure what brings this on, it has happened to me now for the 3rd time though.
Basicly when I launch the remote update over the LAN through firefox, immediately it begings removing everything from the library. I tried to  stop and restart Ubooquity this last time hoping it would stop the removal, but relaunching it just makes it rebuild my library liek its running the first time again.

I have 529 gigs of comics (and growing) so you can imagine rescanning everything takes quite a while.
Besides this little bug though, you have pretty cool software here! thank you for developing it!
Under review
It should obviously not happen. For the moment I have no idea of what might be happening.

Could give me a few details on your setup ?
What kind of device (PC, NAS...) ?
Which OS (Windows, Linux, OS X...) ?
And if you are using Linux, are you using symbolic links for your comics collection ?

If you have a partial log file of the moment the removal starts, it would also help.
And just to be sure, we are talking about the "Launch new scan" link in the "general" section, right ?
Yes I am talking about "Launch new scan" link under general.

My uboquity server is installed on a windows 7 computer that largely functions as a media center kind of computer. However I am reading the comic collection through a mapped drive from a different computer on my network.The other computer that the actual files reside on is also a windows 7 computer.
I actually checked the log file before submitting my issue here to see if it would give any clues but the only log entry between my last  sucessfull scan, and the one where it started deleted jsut started the log with saying it was deleting the entries
I have a similar setup (HTPC under Win 7) except for my files which I stored locally instead of being on another computer.

I suspect the problem might come from the mapped drive although I don't know exactly why. I suppose the drive letter stays the same (otherwise a complete rescan is a normal behavior as files are identified by their path).

If you're interested, I can build a specific debug version for your problem (which would log exactly what happens during the scan so that we can understand why Ubooquity thinks the files have disappeared).

Well, Thank you for the offer, I don't want you to have to build some special version for me especially since it doesn't happen every time. This has occurred 3 times now, but I have also done  dozens of scans that have worked exactly as they should with no issue. (I just did a scan that worked right maybe 12 hrs ago)
I had wondered if the problem was the mapped drive, but the letter does always stay the same, and I'm not 100% sure, but I feel like the first time this happened it was before I moved the files across the network to the other computer. I'm not sure though..
Ok. I'll tag this topic as "not a bug" then.
But if you find anything new that might help to understand the cause of the problem, feel free to post here and we'll work on it again.