0
Answered

Ubooquity stopped working

Rebul 4 years ago updated by Tom 4 years ago 3

Everything was running great, ubooquity was setup to start automatically on server reboot, life was grand. Until today. I couldn't access ubooquity, checked my headless server and couldn't log in to it. Restarted server, but ubooquity doesn't load. Tried to load using "start ubooquity" and get the following message:


xxxxxxxxx@xxxxxx:/opt/Ubooquity$ start ubooquitystart: Rejected send message, 1 matched rules; type="method_call", sender=":1.7" (uid=1000 pid=1472 comm="start ubooquity ") interface="com.ubuntu.Upstart0_6.Job" member="Start" error name="(unset)" requested_reply="0" destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init")


I am a linux noob and have no idea what to do. Please help. I am using Ubuntu 14.04 server. Thanks.



OK, so I tried sudo start ubooquity and works. So now I need to fix the .conf file so that it loads when the system reboots. Again, it was working fine for two days, even with reboots. I followed the directions in this thread. Don't know why it suddenly doesn't work.


Under review

According to the error message you posted, the problem happens even before Ubooquity tries to start.

Perhaps some user permissions changed on your system.


Java (which in turns run Ubooquity) is not supposed to require root permission to run. So I guess that your problem is a symptom of some Linux user or group permissions modification.

But I'm not an expert on that matter, perhaps some other users with more practice will be able to provide more help.