0
Answered

Scanner stops on Synology 216j

Blern Jalkeby 4 years ago updated by Sergio Antonio Delgado Quero 4 years ago 10

Hi, I'm desperatly trying to get this to run on my NAS and it installs and runs (with GUI) as it should. However the scanner always borks up after scanning 50ish comics.


20160511 06:22:21 [Scanner thread] ERROR com.ubooquity.Ubooquity - Uncaught exception on thread: Scanner thread
java.lang.UnsatisfiedLinkError: no javalcms in java.library.path
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1864) ~[na:1.8.0_60]
   at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_60]
   at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_60]
   at sun.java2d.cmm.lcms.LCMS$1.run(LCMS.java:210) ~[na:1.8.0_60]
   at java.security.AccessController.doPrivileged(Native Method) ~[na:1.8.0_60]
   at sun.java2d.cmm.lcms.LCMS.getModule(LCMS.java:203) ~[na:1.8.0_60]
   at sun.java2d.cmm.lcms.LcmsServiceProvider.getModule(LcmsServiceProvider.java:34) ~[na:1.8.0_60]
   at sun.java2d.cmm.CMMServiceProvider.getColorManagementModule(CMMServiceProvider.java:31) ~[na:1.8.0_60]
   at sun.java2d.cmm.CMSManager.getModule(CMSManager.java:76) ~[na:1.8.0_60]
   at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:783) ~[na:1.8.0_60]
   at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:1017) ~[na:1.8.0_60]
   at com.twelvemonkeys.imageio.plugins.jpeg.JPEGImageReader.readICCProfileSafe(Unknown Source) ~[imageio-jpeg-3.1.0.jar.1353531696261016644.tmp:3.1.0]
   at com.twelvemonkeys.imageio.plugins.jpeg.JPEGImageReader.getEmbeddedICCProfile(Unknown Source) ~[imageio-jpeg-3.1.0.jar.1353531696261016644.tmp:3.1.0]
   at com.twelvemonkeys.imageio.plugins.jpeg.JPEGImageReader.read(Unknown Source) ~[imageio-jpeg-3.1.0.jar.1353531696261016644.tmp:3.1.0]
   at javax.imageio.ImageIO.read(ImageIO.java:1448) ~[na:1.8.0_60]
   at javax.imageio.ImageIO.read(ImageIO.java:1352) ~[na:1.8.0_60]
   at com.ubooquity.fileformat.cbr.a.a(SourceFile:89) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.f.a.a(SourceFile:41) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.b.a(SourceFile:63) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.a.b(SourceFile:531) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.a.c(SourceFile:470) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.a.b(SourceFile:35) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.a$1.run(SourceFile:123) ~[Ubooquity.jar:1.10.1]
   at java.lang.Thread.run(Thread.java:745) ~[na:1.8.0_60]


Any ideas what I should do?

Under review

Argh, this problem should have been fixed in 1.10.1.

I don't know what went wrong, but until I do, you can try launching Ubooquity using the command line and adding the flag described in this comment.

I get the same error unfortunately.. :(

This is the command I start it with:


/var/packages/Java8/target/j2sdk-image/bin/java -Dsun.java2d.cmm=sun.java2d.cmm.kcms.KcmsServiceProvider -Dfile.encoding=UTF-8 -Xmx128M -jar /var/packages/Ubooquity/Ubooquity.jar -port 2202 -webadmin -headless -workdir "/var/packages/Ubooquity/"


I've tried 128, 256, 512 and no max memory and deleted and reinstalled both Java and Ubooquity.

Another idea: try to update to the latest version of Java 8 (you are currently using 1.8.0_60, the latest is 1.8.0_92).

I'm not sure of it, but the missing library (javalcms) seems to have been embedded in recent versions only.

Yes, that did it! The error is gone. It now gets stuck on certain books (scanning halts, no error) but at least it runs. Baby steps! Cheers for the help!

Working as intended now - pure awesomeness!

Answered

Great !

I'll update the FAQ and the download page so that users know they need a really recent version of Java.

Still happening to me in my Synology NAS.


Java version:

openjdk version "1.8.0_60"

OpenJDK Runtime Environment (IcedTea 3.0.0pre06) (linux-gnu build 1.8.0_60-b24)

OpenJDK Zero VM (build 25.60-b23, interpreted mode)


Tried using this arguments, same error.


exec /var/packages/Java8/target/j2sdk-image/bin/java -Dsun.java2d.cmm=sun.java2d.cmm.kcms.KcmsServiceProvider -Dfile.encoding=UTF-8 -jar -Xmx512m /var/packages/Ubooquity/Ubooquity.jar -port 2202 -webadmin -headless -workdir "/volume1/tebeos/.Ubooquity"




Other users have solved this by updating to the latest Oracle Java version (8u92).

I didn't realize you could update Synology's Java, but bumping it to 8u101 did the trick. Awesome! :)