0
Answered

Java error during scanning

Freddy 4 years ago updated by Tom 4 years ago 2

Any Idea ?


When Ubooquity starts to scan the comics, it stops.

The log says :


20160616 14:34:27 [Scanner thread] ERROR com.ubooquity.Ubooquity - Uncaught exception on thread: Scanner thread
java.lang.UnsatisfiedLinkError: no javalcms in java.library.path
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1864) ~[na:1.8.0_60]
   at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[na:1.8.0_60]
   at java.lang.System.loadLibrary(System.java:1122) ~[na:1.8.0_60]
   at sun.java2d.cmm.lcms.LCMS$1.run(LCMS.java:210) ~[na:1.8.0_60]
   at java.security.AccessController.doPrivileged(Native Method) ~[na:1.8.0_60]
   at sun.java2d.cmm.lcms.LCMS.getModule(LCMS.java:203) ~[na:1.8.0_60]
   at sun.java2d.cmm.lcms.LcmsServiceProvider.getModule(LcmsServiceProvider.java:34) ~[na:1.8.0_60]
   at sun.java2d.cmm.CMMServiceProvider.getColorManagementModule(CMMServiceProvider.java:31) ~[na:1.8.0_60]
   at sun.java2d.cmm.CMSManager.getModule(CMSManager.java:76) ~[na:1.8.0_60]
   at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:783) ~[na:1.8.0_60]
   at java.awt.color.ICC_Profile.getInstance(ICC_Profile.java:1017) ~[na:1.8.0_60]
   at com.twelvemonkeys.imageio.plugins.jpeg.JPEGImageReader.readICCProfileSafe(Unknown Source) ~[imageio-jpeg-3.1.0.jar.2714122858721618448.tmp:3.1.0]
   at com.twelvemonkeys.imageio.plugins.jpeg.JPEGImageReader.getEmbeddedICCProfile(Unknown Source) ~[imageio-jpeg-3.1.0.jar.2714122858721618448.tmp:3.1.0]
   at com.twelvemonkeys.imageio.plugins.jpeg.JPEGImageReader.read(Unknown Source) ~[imageio-jpeg-3.1.0.jar.2714122858721618448.tmp:3.1.0]
   at javax.imageio.ImageIO.read(ImageIO.java:1448) ~[na:1.8.0_60]
   at javax.imageio.ImageIO.read(ImageIO.java:1352) ~[na:1.8.0_60]
   at com.ubooquity.fileformat.cbr.a.a(SourceFile:89) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.f.a.a(SourceFile:41) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.b.a(SourceFile:63) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.a.b(SourceFile:531) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.a.c(SourceFile:470) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.a.b(SourceFile:35) ~[Ubooquity.jar:1.10.1]
   at com.ubooquity.data.feeder.a$1.run(SourceFile:123) ~[Ubooquity.jar:1.10.1]
   at java.lang.Thread.run(Thread.java:745) ~[na:1.8.0_60]


Thx


freddy

Hi,


Problem solved after long search.

I installed Ubooquity on a synology NAS with DSM 6.0 and Java 8.

that installation caused the problem as discribed above.


I updated the java version to 8.91, restarted the server and it worked !

Thought i should share...


Freddy

Answered

Thanks for sharing !

Your problem was probably similar to this one.