+1

Ubooquity behind haproxy issue

Alto Finnegan 4 years ago updated 4 years ago 3

So, I've tried to run Ubooquity behind haproxy instead of nginx (which worked fine). I can't get it working though. The login page displays fine, but as soon as I login (which also seems to work fine according to the Ubooquity log), I'm getting this error:


502 Bad Gateway

The server returned an invalid or incomplete response.


I might very well have something misconfigured, but it could also be that Ubooquity sense back some slightly wonky response that nginx doesn't mind, but haproxy does.


Does anybody on here run Ubooquity behind haproxy by any chance? Or have any idea what the issue could be?


I have the same issue.

This is strange because the admin connection works correctly but not the user connection.
I think Haproxy receives à bad HTTP header from ubooquity...


Hi,


I'm trying to setup web proxy on my synology to accelarate browsing, but I don't understand how I can configure that in conjunction with ubooquity: how did you configure nginx?

@Moon: yes, I also think it's a bad header


@Elouan: just a normal nginx reverse proxy, something like:


location /ubooquity {

}

This won't make it any faster though, not sure what you mean with accelerate browsing...