0
Not a bug

Scanning for ebooks hangs

Alto Finnegan 4 years ago updated by Jose Ignacio Berreteaga 3 years ago 4

I seem to have a problem with scanning ebooks after setting up a new instance of Ubooquity. Libraries that work fine don't anymore, and I'm not quite sure how to debug this. The only difference to my setup is that I'm using LXC instead of docker now, as far as I know.


On the initial scan, the scanner thread works fine initially, but than hangs at always the same book. If I delete that book, it will work for a few more, but than hangs on another one again. Restarting doesn't help, it'll hang on the same book again.


This is the log message where it hangs:


[Scanner thread] INFO com.ubooquity.fileformat.epub.b - Reading metadata of epub file:


Since all my books worked before, I guess its something with my setup, but I have no idea how to figure out why Ubooquity can't read the metadata of certain books. I've enabled the --debug option, but that doesn't seem to give me more output. I've also tried to send a signal ( kill -9 1149

) to the java process to get a stack trace, but nothing happened.


Any ideas what I can do to figure out what's wrong?

Under review

Sorry, Docker and LXC are out of my field of expertise.


I can only tell you to use "kill -3" instead of "kill -9" to get a thread dump (and then to look at the standard output of Ubooquity, not the logs).

Or just use jstack.

Ah, sorry, meant to say I used kill -3.


Forgot to report back here, but I figured out what the issue was. I had the database file on an nfs share, and that turned out to freeze the whole thing once there was too much updates to it going on.


Thanks!

Not a bug

You're welcome, happy to know it's working. :)

Hi, I have realized that I have the same problem, Is there any solution to maintain the database in the nfs unit?