+1

After update on Qnap to v 4.3.1 i cant access ubooquity anymore. Anyone experienced that issue?

fgillinger 3 years ago updated by Zmajur 2 years ago 15

After update on Qnap to v 4.3.1 i cant access ubooquity anymore. Anyone experienced that issue?

my qnap run on 4.3.3.0096

when i upagred, i needed to delete app and reinstall , rescan and it was ok now on https

how did u set that up?

Worked like a charm! thanks alot! :)

And it died once again :(

Kenji how did you put it in https?

I also can't get Ubooquity to work now that I've upgraded to 4.3.3.0095. The site can't be reached when trying to get to the admin page for it. I've uninstalled and reinstalled version 1.10.1 but it hasn't helped. Any help would be appreciated to get this going again!

on my qnap TVS882

4.3.0096 (96 is version for x82)

packages :


- ubooquity 1.10.1 dkpg 64 bits

http://positiv-it.fr/QNAP/APP/UbooQuity_1.10.1_x86_64.qpkg.zip


- QJDK8 1.8.111 64 bits

http://www.positiv-it.fr/QNAP/APP/QJDK8_1.8.111_x86_64.qpkg.zip


I do not know if it's useful or not

Download the QTS 64-bit compatibility tool, and install in QTS.


unzip and install manuel via app center each package


ubooquity on SSL


- have a valid SSL certificate on the NAS (I paid mine 20 € for 4 years on a domain)

- have a CRT file and a KEY file (I did not test with let's encrypt, but this is possible)

- installed java

Purpose: to create a JKS file to be filled in the admin interface of ubooquity.

You must connect in ssh on the server

In my case I have a file on / share / scritps / ubooquityI copied into my / share / scritps / ubooquity folder for a more convenient side these two files:


CERTIFICATE.crt (not the intermediary)

private_kay.key


Replace PASSWORD with your password
1. openssl pkcs12 -inkey /share/scripts/ubooquity/PRIVATE.key -in /share/scripts/ubooquity/CERTIFICATE.crt -export -out /share/scripts/ubooquity/ubooquity.p12 -passout pass:PASSWORD
then 
2. keytool -importkeystore -srckeystore /share/scripts/ubooquity/ubooquity.p12  -srcstorepass PASSWORD -srcstoretype pkcs12 -destkeystore /share/scripts/ubooquity.jks -deststorepass PASSWORD

result this  :
Entry for alias 1 successfully imported.
Import command completed:  1 entries successfully imported, 0 entries failed or cancelled

a new file JKS is create
and admin ubooquity : 
KeyStore file path    /share/scritps/ubooquity/ubooquity.jks
KeyStore password    PASSWORD

done :)



an example :






Thank you for the reply Kenji, lots of good information there.


I am wondering why I would suddenly need a certificate and key to get this to work now though? On QTS 4.2 all I had installed was the ubooquity 1.10.1 package and it's required dependency, QJDK8 1.8.111 64 bit. Then it all just worked. Did security tighten up with QTS 4.3 that now warrants me needing to take these extra measures you mentioned just to get this to work again?

an error on path on 2


1. openssl pkcs12 -inkey /share/scripts/ubooquity/PRIVATE.key -in /share/scripts/ubooquity/CERTIFICATE.crt -export -out /share/scripts/ubooquity/ubooquity.p12 -passout pass:PASSWORD
then 
2. keytool -importkeystore -srckeystore /share/scripts/ubooquity/ubooquity.p12  -srcstorepass PASSWORD -srcstoretype pkcs12 -destkeystore /share/scripts/ubooquity/ubooquity.jks -deststorepass PASSWORD

For Qnap users who is trying to run command on path 2, they must navigate to java bin folder


cd /share/CACHEDEV1_DATA/.qpkg/QJDK8/jre/bin/

And then execute command... (dont forget to change corespoding path) 


./keytool -importkeystore -srckeystore /share/CACHEDEV1_DATA/.qpkg/UbooQuity/ubooquity.jks -destkeystore /share/CACHEDEV1_DATA/.qpkg/UbooQuity/ubooquity.jks -deststoretype pkcs12

By the way, Kenji, big thanks for the guide. 

+1

In fact, I replied to fgillinger who asked me how i switch to ssl ubooquity

We can of course do without it, but in my case I was switching to ssl on synology which had a known bug in non-ssl mode (with ios)

My installation work with and without ssl (ssl is optional), but this should help you can also be

So you do not have to switch to ssl if you do not want it

+1

Ooh, I just fixed it. Thanks for your help. So what I did was I uninstalled Ubooquity 1.10.1, QJDK8 1.8.33 (I noted that I actually had an earlier version than the one you linked me to), and JRE 8.101.0. I then reinstalled each of them, including the newer version of QJDK8. Once all that was done it loads up for me again.


Now to begin the long process of starting a fresh scan of my collection.


Really appreciate your taking the time to help me out. Thanks!

+1

I'm glad you found the solution

Great! got it to work too :) thanks you so much!! :)