0
Planned

[2.0] Mounted drive not available

christophe.ourliac 3 years ago updated by Bobby Hill 3 years ago 10

In 2.0 when adding new folder - mounted network drives are not visible



thats strange, it is working for me on a windows 10 machine.

Under review

Just tested on my Windows 10 (I don't have any Windows 7 PC available), and it's working too.


To be visible in the list, the root folder (mounted network drive or local, doesn't matter) must be "readable". I guess that might be the reason you don't see them.

Do they need special credential to be accessed ?

In any case, try accessing them using Windows explorer first (so that the crendentials are registered by Windows), then through the Ubooquity admin.


I don't know if it will work, but that's the only thing I can think of right now.



Same problem here.  With the 1.X versions, I was able to specify a UNC path that went straight to my network storage.  Something along the lines of \\drobo\comics\marvel.  Being able to do this matters because I was running this on a server as a service.  In that state, mapped drives are unpredictable, however UNC's are golden.


Regardless, just trying to get a basic mapped drive to be seen is failing.  Tried editing the json directly, but that was a fail because of no corresponding database entry.

+1

Just a thought, but a way around this would be to have the ability to manually enter a path instead of going through this file system GUI, or at least having that as an option.

I think this would be a great addition. I am missing this function also on linux.

Planned

I agree, I added this feature to my backlog (as usual, no ETA).


In the meantime, you can add UNC paths by editing directly the Json preferences files after having stopped Ubooquity.


Example of comic section settings containing an UNC path:


"comicsPaths" : [ {
    "pathString" : "C:\\Users\\Tom\\Libraries\\Demo\\Comics",
    "userName" : [ "Tom", "Kim", "William" ]
  },
  {
    "pathString" : "\\\\terebi\\Documents\\Comics",
    "userName" : [ "Tom", "Kim", "William" ]
  }  ],

Note the escaping of the backslahes: 2 for 1, 4 for 2.

Sounds great, I'll give this a try and post if it's an issue.

So it didn't behave well with my mapped drive, but it's doing a complete scan with UNC paths.  In the end, that exactly solves my issue, so thanks!

Working here, on Win7.  I wonder if it's because I've mounted my folder that holds my Comics folder...


My Comics folder lies inside my R: drive.