+1
Fixed

[2.0.2] first time run headless w/ remoteadmin does not proceed past setting up new password.

keith 3 years ago updated by Tom 3 years ago 15

I've gotten the .jar running with oracle jre 9 as per a few other threads, but when I run the server the first time (--headless --remoteadmin) and go to http://ip:2203/admin/ it prompts me to create the new admin password then sits there timing out with a spinning circle.  It does not proceed any further, there's no further relevant output in console after it does the initial version check, and quitting/restarting just prompts me to create a new admin password again.


Am I missing an obvious step here, or what can I do to rectify this?  It is a headless VM so while I can monkey around with ratpoison or xpra to run the GUI in a container of some sort, I'd rather not if I can avoid it.


edit - the library also responds on :2202 but states there's no permission to view anything (I'm assuming due to not having created any users or added any content).

Hi,


I'm running headless with remote administration and did not face the issue.


Did you try to restart a fresh install from scratch?


Your VM runs which OS?

It's a brand new install of Ubuntu 17.04 with Oracle JRE 9.


As far as a 'fresh install from scratch' is concerned, I'm not sure what you mean.  I've re-downloaded the .jar and ran it from different locations, and it does generate the theme/log/etc folders. The logs mirror the console output, which is to say nothing shows up after I enter in the new admin password twice.  It just sits there and spins.


Is there a way to manually create an admin password from the CLI or in the preferences file?

what CLI command do you launch?

Do you launch it from the folder of execution?


For the admin pwd creation from the CLI I'm not aware of any command unfortunately...

I make a folder called "Library" in /home/keith/ , download and extract the jar to there and run as follows ;


# java -jar Ubooquity.jar --headless --remoteadmin

I've also now installed Oracle JRE9 on a Debian 8 VM I had handy, same issue and same results.

Do you see any entry in the ubooquity logs?

Nope, as I mentioned above the last thing I see in the console is what is mirrored in the logs -- the version check on startup.


20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - Running with the following parameters - headless: true, libraryport: -1, adminport: -1, remoteadmin: true, host: null, debug: false, execdir: /home/keith/Library
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - #############################
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - #     Starting Ubooquity    #
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - #############################
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - Java version: 9-ea
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - Java vendor: Oracle Corporation
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - Max heap size available: 239 MB
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - OS name: Linux
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - OS version: 4.10.0-19-generic
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - OS architecture: amd64
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - Loading local version info
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - Ubooquity 2.0.2 built on 2017-04-24 at 20:52
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - Creating application folders
20170510 16:26:00 [main] INFO  com.ubooquity.Ubooquity - Loading preferences
20170510 16:26:01 [main] INFO  org.eclipse.jetty.util.log - Logging initialized @2941ms to org.eclipse.jetty.util.log.Slf4jLog
20170510 16:26:01 [main] INFO  com.ubooquity.b - Starting internal server...
20170510 16:26:01 [main] INFO  com.ubooquity.b - Reverse proxy prefix is not activated
20170510 16:26:01 [Scanner thread] INFO  com.ubooquity.data.feeder.a - Scanning books directories
20170510 16:26:01 [Scanner thread] INFO  com.ubooquity.data.feeder.a - Finished scanning books directories, populating folders content cache
20170510 16:26:01 [Scanner thread] INFO  com.ubooquity.data.feeder.a - Books folder content cache populated
20170510 16:26:01 [Scanner thread] INFO  com.ubooquity.data.feeder.a - Scanning comics directories
20170510 16:26:01 [Scanner thread] INFO  com.ubooquity.data.feeder.a - Finished scanning comics directories, populating folders content cache
20170510 16:26:01 [Scanner thread] INFO  com.ubooquity.data.feeder.a - Comics folder content cache populated
20170510 16:26:01 [Scanner thread] INFO  com.ubooquity.data.feeder.a - Comics statistics: [total: 0, added or updated: 0, removed: 0]
20170510 16:26:01 [Scanner thread] INFO  com.ubooquity.data.feeder.a - Books statistics: [total: 0, added or updated: 0, removed: 0]
20170510 16:26:01 [main] INFO  org.eclipse.jetty.server.Server - jetty-9.4.0.v20161208
20170510 16:26:01 [main] INFO  o.e.j.server.handler.ContextHandler - Started o.e.j.s.h.ContextHandler@55f3c410{/,null,AVAILABLE,@admin}
20170510 16:26:01 [main] INFO  o.e.j.server.handler.ContextHandler - Started o.e.j.s.h.ContextHandler@11acdc30{/,null,AVAILABLE,@library}
20170510 16:26:01 [main] INFO  o.e.jetty.server.AbstractConnector - Started library@5b198648{HTTP/1.1,[http/1.1]}{0.0.0.0:2202}
20170510 16:26:01 [main] INFO  o.e.jetty.server.AbstractConnector - Started admin@718ff66b{HTTP/1.1,[http/1.1]}{0.0.0.0:2203}
20170510 16:26:01 [main] INFO  org.eclipse.jetty.server.Server - Started @3213ms
20170510 16:26:01 [main] INFO  com.ubooquity.b - Internal server started. Listening on port 2202 (library) and 2203 (admin)
Tyep Q then ENTER to exit
20170510 16:26:02 [Timer-0] INFO  com.ubooquity.Ubooquity - Checking latest available Ubooquity version from website
20170510 16:26:03 [Timer-0] INFO  com.ubooquity.Ubooquity - Latest version available: 1.10.1 - Current version: 2.0.2


hum... I don't spot any obvious issue in your logs... I checked mines and have similar entries...


my command line is: nohup java -jar /location/to/Ubooquity.jar --libraryport 2202 --adminport 2203 --remoteadmin --headless /location/to/ 2>&1 &

Could you try?

Maybe retry with debug mode activated...


PS: above simplified version of my real one: 

nohup java -Dlogback.configurationFile=/mnt/NAS/Docs/e-book/Ubooquity/log-config.xml $MEM_OPT -jar /etc/ubooquity/Ubooquity.jar --libraryport $LIBRARY_PORT --adminport $ADMIN_PORT $ADMIN_MODE $GUI_STATE /etc/ubooquity/ 2>&1 &

Still the same result, just sits there and times/spins.


edit - on a whim I even went and install Oracle Java 8 and set it as default, still same results.

I just tried to install Ubooquity 2.0.2 on my Synology via Zerpex docker container (https://github.com/zerpex/ubooquity-docker) and have the same Problem. 

While looking at the admin pages source code I noticed that the call to "admin-res/cryptoparams" returns the source code of the admin page.

Then it's too much for me to help. Sorry...

+1
Under review

I have managed to reproduce the problem.

To work around it, make sure you don't have a slash at the end of your admin page URL.

(and let me know if this worked or not)


Bad:

localhost:2203/admin/

Good:

localhost:2203/admin

I'll try to find a way to prevent that.

Slashes management in HTML/JS code has been a problem for me for a long time. :/


Yup, works fine without the slash.

Thank you very much.

Awesome, that also cleared it up for me.  Thanks for the workaround Tom.

Fixed

I added some code in 2.1.0 to automatically remove the trailing slash.

This kind of "trap" is really bad for usability.