0
Answered

Page not found when trying to access webadmin using linux build.

dpg10 5 years ago updated by Lane Haygood 5 years ago 13
I don't know what I am doing wrong. I downloaded Ubooquity and go it to run and host the server. But every time I try and set an admin password I click set password and get a page can not be found error. No matter what I do I am unable to access the admin portion of the server. I am trying to run a headless server on my Linux OpenMediaVault NAS. Any ideas? Thanks!
Under review
When you click "Set password", Ubooquity should take you to the exact same URL than the one already displayed on your browser address bar (for instance: http://10.0.0.1:2202/admin) and a "webadmin.cred" file should be created in the working directory of Ubooquity.

Could you check if the file is created ? And check if you see anything suspicious (warning or error) in your log file ?
When I click set password no file is created. It just goes to page can not be found. When I go the main ip address, It tells me that I do not have permission to view anything on this server. But if I go to the admin page it will ask for me to set the admin password. Just wont get past that screen. I don't know if there is additional permissions or settings I need to do or change. I followed the directions 100%.
"Sorry, you are not authorized to access any file on this server"
This screen is shown by default when you don't have configured anything yet. So it's perfectly normal in your situation.

As for the "page not found", I'm puzzled.
Could you send me your log file ? ("ubooquity.log" from the "logs" folder in your working directory)

Email to: tom ' at ' vaemendis ' dot ' net
I just emailed it to you. Thanks for your help!
Like I said in my email, I did not find anything in the logs. Sorry.
I've the exact same problem with 1.7.5 - I also tried 1.7.0 and got the same issue.
Ubooquity is running as root (for testing, will change it later) so there should be no issues with permissions.
Thanks for your help !
FYI, I think I found the issue. I was accessing the admin through http://localhost:2202/admin I tried http://127.0.0.1:2202/admin and it worked. It might help.
I tried to reproduce the problem o nmy Raspberry Pi (under Raspbian), but to no avail.

And since the "Set password" button just takes you to the "/admin" page (it doesn't do anything complex), I still haven't a clue as to why you have this problem.

Could you describe the setup in which you reproduced it ? (browser, operating system, device...)
I have been playing with the folder and file permissions for Ubooquity. Kind of got it working. Basically gave permissions to the rules and folder for the user that is running the Java .jar. In my cause it was root. Still not 100% sure what I did to get it working. I was able to add a comics folder but I can't seem to access the admin page anymore.
Ubooquity needs to have writing permissions on the working directory (the one from which the Ubooquity process is launched) so that it can write (among other files) the "webadmin.cred" file which contains the hash of the admin password.

Apart from that (and reading rights on the comics/books folders of course), I can't find any link between permissions and the problem you have.

Had this same issue -- switching from Chrome to IE fixed it for me. Try that and see if it works.