0
Answered

Hi! Not good with Linux but would appreciate any help with a QNAP ARM NAS install?

Rajeev Iyer 5 years ago updated by Tom 5 years ago 8
Help Please!

I know how to access the SSH terminal, but I am not very good with installing webservices. I have a QNAP ARM NAS device and would appreciate any help in installing the webserver.
Under review
A QNAP package is available here.
It has not been package by me (I don't own a QNAP NAS), but according to the feedback on the linked forum, it seems to work.
As to how you install a QNAP package, I have no idea, but I suppose this is documented somewhere in the NAS manual.
Thank you Tom. Unfortunately the Qnap package is only available for an x86 device not ARM. I have had some limited success following the Linux instructions but the server is very unstable. I cannot seem to access the library easily.
Oh, ok.
By limited success, you mean you managed to run Ubooquity ?

Ubooquity itself doesn't care if you run on a x86 or ARM processor. It just needs Java (which has indeed different versions for x86 and ARM).
ARM Java for QNAP seems a bit complex to install, but still doable:
http://wiki.qnap.com/wiki/Category:JavaRuntimeEnviroment

Once Java is installed, Ubooquity can be run, although I don't know if QNAP NAS have specificities that has to be taken into account.
Yes. I got it to run, but cannot get it to boot on load. Its being run manually through a Putty Session. Also, after adding all the comics I had, on loading of the webserver through the browser, the Comics page just showed a blank screen. Not sure if I need to delete the old cache files and start again.
You can see how many comics were found by Ubooquity on its administration screen.
If you have a "Total comics" over 0, then you should see them.



When you say "blank screen", you mean completely blank ? Or do you see the Ubooquity interface, but without any comics ?
The Total Comics is greater than Zero, about 2000+ in the admin interface. However when I navigate to the Ubooquity interface, I can see the interface and the navigation interface, but the comics themselves are missing. Its very weird. It worked the first time I ran it, but subsequent runs have failed.
Did you activate user management (acess using a login and a pasword) ?
Because if you did, you have to explicitely authorize each user for each folder you share.

If not, I have no idea what's happening.