0
Not a bug

[2.0.2] Memory?

Telecart 3 years ago updated 3 years ago 8

I've had ubooquity open on my Mac Mini server for maybe a week now, using it intermittently. Noticing some sluggishness, I opened activity monitor and noticed the "launcher" app is now taking well over 1GB of RAM. I closed Ubooquity and reopened it and it seems fine, but wondering if there's a memory management issue maybe.

Not a bug

Appart from any potential memory leak in Ubooquity (there still might be some), Java will generally use as much memory as you give it when working on memory intensive operations (image handling in Ubooquity for instance).

To restrict the max amount of memory Ubooquity can use, your have to launch it using the command line and the "Xmx" flag.


For instance the line

java -Xmx512m -jar Ubooquity.jar

will launch Ubooquity and give it a maximum of 512 MB to work with.

oh interesting. That's useful to know.


However, when I launch it like that, it seems to "forget" I have already set Ubooquity up... It asks for a new admin password etc... Any way to run that on an existing instance without it "resetting"?

Does your execution directory have proper acces rights (read and write) for the user you are running your command with ?

uhm.. I mean, I think so? My user has admin access. Is there any easy way to test for this (I'm on OSX)?

I'm asking because Ubooquity keeps user settings in files it creates when running.

If it can't create the files, settings will be lost when Ubooquity is stopped.


You can check if the settings files are properly created (and modified) when you run Ubooquity. Easiest one to check: preferences.json

yeah when I run with 

java -Xmx512m -jar

it definitely isn't modifying the preference.json or anything in the folder. Far as I can tell form the logs, it's running in the home folder instead of /Applications/Ubooquity

+1

You have to run it in a directory with writing rights ("cd" into the one you chose before typing the java command).

ah! That worked! Thanks.