0
Under review

[2.0.2] Unable to access from Public IP address

austin.whipple 3 years ago updated by Baz 1 month ago 12

I am unable to use my public IP address to browse Ubooquity, but I can do it locally, and from other computers on my network, including the router.


Things I have tried/confirmed:


1) Port is open on both the router and the modem. Using online port checking tools shows that it is reachable.

2) Trying with/without SSL enabled. SSL handshake does come up with a warning (since it is self-signed), suggesting they are getting the initial packets from the ssl-handing-part of the server

3) Problem exists with Windows Firewall turned on or off. There is an explicit rule for incoming connections on that port regardless.


Browsing straight to it just hangs for a long time until timing out. Using the default port.

Additional points of clarification:


4) There are other servers, such as Plex, on the computer that can be connected to from the internet

5) I was able to curl the root page / from the router and successfully get the logon screen, with and without SSL enabled.

Are you on a VPN? Proxy?  Something?

Under review

Two points that are new to Ubooquity 2.0.X (just in case it could help):

  • there are two different ports: one for the library (2202), one for the admin page (2203)
  • by default, the admin page can not be reached from an external machine, you have to explicitely allow remote administration (either on the desktop UI if your run Ubooquity by clicking on the jar, or using the --remoteadmin command line argument)

I wasn't able to get it to work, so I just made a Google Cloud instance and put it on there. It works up there. Not sure if it was something about running it on Windows, or something about Comcast not wanting me to serve web traffic from a personal IP address.

I have the same problem running on an instance of Ubuntu 16.04 with a public IP.


I confirm ubooquity is running from the command line:

root@bizlib:/home/ubooquiter# ./ubooquity.sh status

 * Ubooquity is running


From my browser:

http://999.999.131.76:2203/


Results in:

This site can’t be reached

999.999.131.76 refused to connect.

Try:

ERR_CONNECTION_REFUSED



2203 is the ADMIN port.  2202 is the Library port.


Accessing the Admin page from an outside network takes some config change, that I can't remember because I haven't bothered with it.   It's somewhere here in the forums.

I get the same error for port 2202.

what did you do to get it working again?

I'm suddenly having this same issue now. i can't connect to the public network address. setting it up and trying via chunky, i get a connection failed. when i just click on the public link in the server gui, i get the "site cant be reached. refused to connect" message.

i did have a hardware change though. i upgraded to a newer, faster cable modem but everything else stayed the same. i did a hard reset on my wifi router so if i had any specific port forwarding, it's gone now. i dont recall having to do anything special w/ ubooquity though. everything else on my network works the same and as it did before the new modem (like my Plex server). only ubooquity is giving me issues now. is there anything else i can try? im on Windows 10, if that helps.

Perhaps it's link to IPv6.

I'd tried with my IPv4 with no issue, but when i use a DNS (that use IPv6) or IPv6 directly i can't reach the webapp.

Did someone success to connect ubiquity in ipv6 ? (probably some java limitation)