0

HTTP ERROR 500 admin page in 2.0.2

Skylar Ragan 3 years ago updated 3 years ago 2

When I try to access the admin page, I get: 

HTTP ERROR 500

Problem accessing /admin. Reason:

    

Could not find matching provider (wrong URL)


I setup a new install of 2.0.2 on a headless Ubuntu 17.x VM in Google Cloud. On that server I'm using nginx to access pages remotely.


Here are the relevant entries in nginx:


# Ubooquity
 location /ubooquity {
auth_basic off;
proxy_pass http://127.0.0.1:2202;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forward-For $proxy_add_x_forwarded_for;
 }
#
# Ubooquity Admin
 location /admin {
auth_basic off;
proxy_pass http://127.0.0.1:2203;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forward-For $proxy_add_x_forwarded_for;
 }



I'm using the following command to start Ubooquity:

 sudo java -jar /opt/ubooquity/Ubooquity.jar -remoteadmin -headless


So if I go to https://my.domain/ubooquity I get the "You aren't authorized" whatever whatever stuff, which makes sense because I haven't created any users yet. So the library port seems to be working fine. However, when I go to https://my.domain/admin I get the error described at the top of the page. What am I doing wrong?

Oh, I did go into the preferences.json file and manually set   "reverseProxyPrefix" : "ubooquity",

I've resolved this thanks to the comments on this post.