+1
Under review

[2.1.0] Error: Cannot insert bookmark for a book/comic that does not exists

ubooquity_37b645 3 years ago updated 3 years ago 8

Fresh install of Ubooquity, deleted and rescanned the library. I am able to open the reader interface and read books/articles, but on every page view I see an error like this on the console where I am running the JAR file interactively:


20170718 08:20:44 [qtp1022081840-71] ERROR com.ubooquity.provider.api.user.b - Cannot insert bookmark for a book/comic that does not exists


Here's my Java version (java -version):


java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)


I'm running Ubooquity like so:


java -jar Ubooquity.jar --headless --remoteadmin --debug


I tried using multiple browsers, also, from multiple machines, just to make sure it wasn't something wonky with a browser extension or caching.

Forgot to mention, when I exit the book/document and return to it, I do not resume it at the previous location where I left off (presumably because the bookmark was lost).


Please let me know if there is additional information or troubleshooting steps I can perform to help isolate what about these circumstances is causing this issue. I don't see others with this issue, and this was a freshly-built VM for the purposes of testing this in a demo environment, so we can do whatever we need to do.

I am seeing the exact same issue.  I have also tried multiple browsers and I get the error on quite a few books, while some books I do not get the error.  I am hosting from Windows 8.1 with Java 8 in interactive mode as well.

This bug is the only issue currently stopping me from my whole extended family from using the tool as well as my work (which could expand to up to several hundred users).  Please fix this ASAP as Ubooquity has tons of potential already even with the bug!  I will most definitely want to donate some money once this bug is fixed, as there is no web-based tool that is nearly as easy to setup and use as Ubooquity.

+1
Under review

@ubooquity_37b645 : sorry for not answering, your message came at a time I had not much time to answer, I forgot to go back to it afterwards.


Both of you: I have been able to reproduce the issue with PDF shared in the "books" section. I'll fix it. Does it happen in other cases for you ?

@tom, nope, now that you mention it all I copied over for my testing were PDFs, since that's about 97% of what I read these days. I spooled up my play instance for a few minutes and copied over an ePub and that worked fine. So, I am only experiencing this with PDF documents. Thanks for checking.

At the moment my comics all work...and in fact some of the books work as well.  Thanks for reproducing, I'm very excited to start using Ubooquity more and more :).

It works!  I tried the new version 2.1.1 and you've fixed it, atleast for the books I have tried it with :).  Thank you very much, you will be receiving a donation from me very soon...

Version 2.1.1 has resolved this issue for me, as well. Thank you!