0
Under review

Way to disable Public Network access

asian flavor 5 years ago updated by Tom 5 years ago 9
I was wondering if there is a way to disable the Public network access? I have IIS setup with the URL rewrite module and with Ubooquity, it's conflicting my own HTTPS broadcast. With the URL rewrite module, I can tell all external calls to redirect to any internal port. If I set up the URL rewrite to point to Ubooquity, it shows the login screen but will not get into the site. Hopefully I'm making sense here... been a long day at work.
So turning on the HTTPS with Ubooquity took out another one of my web programs. So, I would like to explain my setup. I have a Windows 7 'server' running IIS 7.5 with the URL rewrite module. On the Windows 7 side of things, I'm running Ubooquity, Subsonic media server, and using the built-in Webdav. Then I also have Mint running in a VM that hosts my Owncloud setup and Openfire chat service. I have my traffic for everything going through HTTPS. As of now, Ubooquity is the only thing that is running HTTP. As soon as I turn HTTPS on with Ubooquity, it's own external broadcast starts confusing my IIS setup.

When I setup the URL rewrite for Ubooquity, it will show the login field with the Ubooquity banner or black background. When I login, I get an IIS error page stating the page is missing. So if there is a way to disable the web service for Ubooquity, I can get everything working together perfectly. Thanks!
Just a shot in the dark: It appears you have configured a URL rewrite in your IIS setup and have also specified the reverse-proxy path in the Ubooquity. Maybe they are conflicting with each other? You may try removing the reverse-proxy path from the Ubooquity config and see if that helps. When you log in, is the URL path in your browser what you expect to see?
I have took off the reverse proxy path in Ubooquity and still the same error. The url path is correct. Pretty sure the external broadcost is the cause of the conflict. I have set up Ubooquity just like my Subsonic server. Using a different port for each and having the URL rewrite module point to them. The only difference that I can see is that Subsonic's jetty server is not broadcasting externally. If I have to keep Ubooquity on HTTP, that's fine. But would love it if I can have it behind a SSL connection.
Under review
I'm not sure I understand what you mean by "external broadcast". Ubooquity does not broadcasts anything, it just opens a socket to the port specified in the preferences and answer requests.

There is one thing though: Ubooquity does its binding using a "wildcard" hostname, meaning it will listen to all available network interfaces. I suppose this might cause problem when other processes try to use the same port on one specific interface.

Do you think this way of opening the socket might have something to do with your problem ? If so, I could give you a test version with an option to explicitely configure the network interface Ubooquity has to bind itself to.
Broadcast is probably the wrong term. Binding is what I was looking for...LOL. Here's what happens when I use the URL rewrite with Ubooquity:


After logging in, it goes to my home page, instead of the comics. I would gladly like to test out Ubooquity with that option. Thanks for looking into this!
I'll work on it, but I can't say when it'll be done.
Here is the promised test version.

The hostname can be forced using the new "-host" command line argument, e.g:

java -jar Ubooquity.jar -host 10.0.0.5
Let me know if it helps solving your problem.
Sorry for not responding to your message 4 days ago. Had to prep to do 2 BBQ's and got sick during this. Love having kids that are sick...LOL! Just tested it out the new test version and no go. The public address is still conflict with my IIS. I set the -host with my LAN IP of my server and it still only shows a login screen with no background. After I login, it goes to my portal signin page. So the setup I have with this test version:
IIS is running only HTTPS for my website
Ubooquity test is on internal LAN IP running on port 85.
IIS URL rewrite is pointing to the IP that Ubooquity is running on with port 85.

Ubooquity is still binding to my WAN IP and pretty sure that is the cause. If I have to keep this running with HTTP on port 80, that'll be fine. I just want this behind my SSL along with my other programs. Thanks for this and your hard work!
Don't worry, I often let a few days pass before answering messages too.

I'll keep on investigating.