+1
Under review

[2.1.0] add first admin password and reverseProxyPrefix enabled

xenxo1900 3 years ago updated by Hanson Song 4 weeks ago 3

Hello,


 i am having this issue with the docker image linuxserver/ubooquity. the config file  in the image includes "reverseProxyPrefix" : "ubooquity", by default, changing the admin url to "http://<your-ip>:2203/ubooquity/admin/". The bug shows up when you are going to insert on the first time the password. In addition to the error logs (included bellow) makes impossible to add the first password , throwing up javascript exceptions.  


log: 20170805 09:30:20 [qtp936653983-40] ERROR com.ubooquity.provider.api.admin.c - Admin page resource not found: angular.min.js.map
20170805 09:30:20 [qtp936653983-31] ERROR com.ubooquity.provider.api.admin.c - Admin page resource not found: angular-animate.min.js.map
20170805 09:30:20 [qtp936653983-31] ERROR com.ubooquity.provider.api.admin.c - Admin page resource not found: angular-aria.min.js.map
20170805 09:30:20 [qtp936653983-43] ERROR com.ubooquity.provider.api.admin.c - Admin page resource not found: angular-messages.min.js.map


 the workaround that i found, remove the config "reverseProxyPrefix" : "ubooquity" in the file "preferences.json" obiously this change your admin url to  "http://<your-ip>:2203/admin/"

+1
Under review

Hello,


The "angular-*.min.js.map" are not included in Ubooquity, they are Javascript libraries sources that are used only when debugging. I have the same logs when I use the "web developper" screen in Firefox or Chrome.

Would you happen to have used such a feature in your browser ?


In any case, this error has no impact whatsoever.


But there is indeed a problem with the admin and the reverse proxy.

I'm working on it.

5 months in, this is still an issue. unfortunately not documented on the LinuxServer side either, so took me a while to find this post.

In my case, I removed "reverseProxyPrefix", "http://<your-ip>:2203/admin" show up and it prompts to pick a password, but after I submit my password, it just keeps loading, without any further response.


I found the root cause in Chrome DevTool: as soon as submit button clicked, the "password.js" sends a request to the wrong URL: "http://:2203/admin/admin-res/cryptoparams", the correct one should be "http://:2203/admin-res/cryptoparams".

Neither "http://<your-ip>:2203/admin" nor "http://<your-ip>:2203/admin/" helps, I temporarily hack the "password.js" by changing "admin-res/cryptoparams" into "/admin-res/cryptoparams", finally it works, I can continue to login and use the admin pages.