0
Under review

Version 2.1.0.: Configuration/Login no longer possible

Daniel Schuldt 2 years ago updated by Tom 2 years ago 7

I have just installed version 2.1.0 on my QNAP 453b-mini (qpkg from here: https://www.forum-nas.fr/viewtopic.php?t=1371 which have always worked fine) and I have the problem, that I continue to get 


Sorry, you are not authorized to access any file on this server

no matter which page I try to enter (/comics; /admin; etc). It doesn't ask me for a password, just keeps denying me access. I also can't seem to setup a new admin-password as usual after install. Tried uninstalling and re-installing as well as deleting all ubooquity cookies (admin sessions) - didn't help, same thing. Anyone got a suggestion?


Thanks a lot in advance for your help!


+2

Hi,

Did you come from version 1.x?

If yes, then you have to reconfigure from scratch. Tom set a dedicat address & port for admin page, not anymore the same than library port. Check the readme.

+1

Thanks Matthieu, switching the port for the admin page did work. However I now have the next problem: After setting everything up again and scanning the folders (with Ubooquity clearly adding books as well as comics) I do not see any of them when I enter the comic or book segments. There is just the UI on top and below is blank. Any idea what I could be running into now?


Thanks a lot in advance!

Hi Daniel, 


if you set any user security permissions in ubooquity , be sure to set the comic/book path settings without any symlinks -

for example : 

wrong  -  /share/download (it's a symlink generatet by qnap itself)

correct:   /share/CACHEDEV_01/download (this is the "absolute" path on my system, your's may differ, and the above path is the symlink target)

I'vo got the same "problem/bug" on my TS453mini as you, but after changing the path settings to absolute paths & 

rescan the entire database (incl deleting the "old/wrong" informations before the new scan!) all works fine  ..

in my humble opinion the java runtime cannot use or do his job false on symlinks, but using absolute paths is basically safer..


best regards from munich !


TierparkToni

+1

Good. So nothing "unexpected"...


Realise that you have to setup again everything. Including users and access rights on folders. I guess you setup the folders to be scanned but not yet the users...


Tom, just a hint, that as discussed in the past, the lack of settings migration generate users confusion ;-)

+1
Under review

I know, I know...


But I don't even manage to answer all the questions on this forum (much to my shame), so settings auto-migration is waaaaay down on my "should-do" list. ;p


(By the way, I did update the documentation upon V2 release, so...)

+1

Hi Matthieu,


the "lack of settings migration" refreshes sometimes "lost memories" on IT basics :-) 

my comic servers runs 1 day with this "side effect", but running it without any working 

differential security rules keep my mind restless - here with me are some younger 

user/reader who should not read my aduld horror comics like "Echoes "or "From Hell"...


+2

Thanks a lot Anton, that did the trick! Thanks everyone for your help!


Best regards from Hamburg,

Daniel