0

Can't access server externally

PatternRec 2 years ago updated by Anton Baur 2 years ago 5

I can't access my Ubooquity server from the external address. I'm using my external IP followed by :2202 and I get a time out error - Chrome says the site can not be found, took too long to respond. Is there a firewall or router setting I need to check to see where the disconnect may be occurring? 

Hello


Yes you need to open the port you wanna use in your router.

You can check on google how to do it but be careful as it will open a little bit more your local network to the wan.

Cool, thanks. I'll let my roommate know before making any changes to his router. We're both good about keeping our machines and stuff pretty well protected. 

Hello PatternRec,


you opened a year ago a post with nearly the same problem like your current, and my last post shows 

you the current Admin Panel even without any externel IP-Adresses (Tom explained the "why" very detailed) . 

I like to help you, really - but i (and all the other helping board members here) need some more detailed informations 

about your 


a) Ubooquity running hardware and OS (NAS ? / PC ? RasPi ? Linux ? Windows ? version of OS ?) and 

b) some informations about your IT skills (Linux "Rookie" ? / Semi etc. ? ) 


I'm working many years for an big IT Helpdesk service provider as 2nd / 3rd Level IT Incident Expert, 

and my "tech-translate" skills helps me doing my job very well - so can you give me some details about 

your running / planned to run Ubooquity System, please ? 


Ubooquity 2.x runs nearly complete different to Ubooquity 1.x and needs (for the moment) some "deeper IT skills", even more running it stable and full functionally at linux - but with a little bit more detailed information about your system / your network HW we can bring it to run and stable connectable from outside , i promise :) 


best regards


TierparkToni

The one I opened a year ago the person I was subletting from at the time wouldn't allow me access to his router so I never followed up on the instructions as the point was moot. I wasn't able to make the necessary change. Even had I remembered posting that one I still would have started a new thread rather than bumping one that was a year old and based on different circumstances. 


I'm running Ubooquity on Win 10 on a desktop PC. I'm using Windows default firewall, and having had a similar issue with Plex (another media server), the first thing I checked was too see if Ubooquity was blocked there. I didn't see it listed at all, no block nor an exception, so I tried adding one but the firewall didn't recognize the .jar file so I couldn't add it. I'm not really sure if there's a diff way to add it to Windows Firewall or not. I usually don't mess with the Firewall that much. 


As for the router, I didn't need to do anything on it to allow Plex to go through, but I'm sure it uses a different port than 2202. I don't know routing well, but my level of tech understanding is pretty good. Over the last 25 years I've opened or forward ports when I had my own router (followed instructions since I don't do it every day, but routers are pretty easy, especially moderm firmware). My new roommate should trust me enough to make the change (or to make it himself for me if he doesn't want me in the router).

Good Morning PatternRec (its actual 07:40 AM in Munich),


we're on a good way to bring your Ubooquity Server with external access to run. 


first of all, you have to allow the javaw.exe binary in the Windows Firewall Settings, there's a very good video on YT

The displayed Path in the video may differ to yours, so you have to use your local given Path to javaw.exe.

Allowing the jar-File or add it in the Firewall rules can't work, because the jar-File isnt opening any communication - 

thats the job of javaw.exe from JAVA. 


Then open on your Router the Port 2202 in TCP-packet-Mode forwarding to your local Win10-Network IP-adress for displaying comics, and if you want do admin your library from outside, even open the Port 2203 in TCP-packet-Modus.

That should work - if not, i can post you an more detailed manual to set the necessary firewall allow rules


Hope thats helps 


Best regards


TierparkToni


PS: 

Plex itself either use an own PLEX-Gateway outside in an "swinging"-based communication with your local PLEX behind your router or your local PLEX use the UPnP protocol to open the necessary ports on your router automatically - but this method is general a medium security risc, because any local unrecognized virus or malware can this do, too... and UPnP with JAVA is a very high risc, because there many exploits outside to make your system to a Malware Bot etc., so my opinion is that Tom do a very good programming/coding job to NOT using it :).