0

Version 2.1 on Qnap not reachable

Claus44 3 years ago updated by Anton Baur 3 years ago 12

Here is my experience with installation on QNAP (my NAS is Fujitsu Celvin 902, identical with Qnap 669 Pro), System 4.2.6 (newer firmware is not permitted from Fujitsu).

I have downloaded the version from forum-nas from QoolBox. After installation the admin page was reachable with Port 2203/Admin (important is Slash Admin, because without this, the server was not found). The new administration is very clear and self-explanatory. I created a user test and some paths (in the ui) to different book content.

So far so good.


With user proteced access I could not see any books (as user test). Without access protect I could see all topics (= paths) and in this all books. O.k. now I created the path to the great book index (about 15,000 books). While scanning I could see them growing.


Now, after finishing the last scan (will probably be done, more than 24 hours gone), I cannot reach Ubooquity. Neither as Admin with Port 2203 nor as user test. When I try to login as admin I get the page with passwort question and after this a waiting symbol without any further action. As user test I see the login site (without passwort question because of switched off the security - and nothing happened, no navigation possible.


I have deleted all of Ubooquity 2.1 and made a new installation with the same result. Now I be back transitionally on version 1.10.


What am I doing wrong? Any ideas, any help?

Hi Claus44,


if you set any user security permissions in ubooquity , be sure to set the comic/book path settings without any symlinks -

for example : 

wrong  -  /share/download (it's a symlink generatet by qnap itself)

correct:   /share/CACHEDEV_01/download (this is the "absolute" path on my system, your's may differ, and the above path is the symlink target)


I'vo got the same "problem/bug" on my TS453mini as you, but after changing the path settings to absolute paths & 

rescan the entire database (incl deleting the "old/wrong" informations before the new scan!) all works fine  ..


in my humble opinion the java runtime cannot use or do his job false on symlinks, but using absolute paths is basically safer..


best regards from munich !


TierparkToni


Hi TierparkToni,


thank you for your help. But I cannot try this, because my complete 2.1 installation is not reachable after

scanning the main book folder. I will try it, when I reach the server again. Or do you see a connection between the "absolute path" topic and that I cannot reach the server anyway. See last section in my first post.


Thanks for help in advance.


Claus44

Hi Claus44,


the problem with your unreachable installation refers deeply to the "false symlink" scan path - you can manually stop the running prcess via killing the current running Java instance (" ps -A| grep java" and following " kill <JAVA-PROCESS-ID> "


after you killed the running java process and deleting/move "outside"  everything exept the ubooquity.jar from your current installation directory you can fresh run Ubooquity and set the correct library scan path in the admin panel ..


Hope that helps 


TierparkToni


PS: can you connect via SSH to your NAS or is this even impossible ? 

Hi TierparkToni,


thank you for your description how to start with a new clean Ubooquity 2.1. It works. I am now in the admin panel of a fresh installation. And now I have found the way to choose the correct path to the books without symlinks. After scanning the smaller folders I still get into the admin panel. And the protection of shared content with the user accounts works!


Now I will scan the great library and hope, that tomorrow in the morning everything is scanned and Ubooquity works fine.

 

Hi Claus44, this is nearly the issue like i have.

I was going back to 1.10 as well.

It will be interesting, if this is the solution.

TierparkToni, maybe you remeber my issue. My installation and my share Ebook content on different devices.

And i mount the Harddisk into my Debian system. Could this be a problem?

As i told you at the other Topic, the Java Version and the start parameter are exactly the same (just without the admin Port) and after scan it ist not possible to enter the webcontent at Version 2.10.



Hi Kally,


you tell me now that your content is on a different device - did you "connect" that device via samba/SMB ? 

OMG, that IS the " f***ing " problem (but only >for the moment< with Ubooquity 2.x) :-) !! 


Remote smb-hosted content is under Java8 & Ubooquity 2.x very tricky, because the Java8 runtime, the smb network user and the remote user must apparently be the same name & password  and you have to use the real path given by the linux mount-subsystem - i tried this and after some hours spend in many failtures and crazy bugs, i give up (but just for the moment :) )


It works perfect under Ubooquity 1.x (like my old installation, Ubooquity 1.x on NAS A (Intel x64), content on NAS B (ARMv5 x32), but with Ubooquity 2.x it "really sucks" - the Java runtime has apparently more restrictions following mounted shares or symlinks, because both are no really "direct paths" to the content and differs in the linux mount subsystem background with the given access rights... 


so, either use smb-content with 1.10.x or put 2.x and content on one machine (perhaps with USB?) and use 2.x 


Sorry for not really helping you, but knowing it will >currently< not work gives you a "clean" way ahead spending time for reading books & comics with the good old Ubooquity 1.x 


best regards - and keep reading ! 


TierparkToni 

Hi TierparkToni and Kaily,

unfortunately it did not work.  After finishing scan, I could not reach the server. Se some pictures:




The last images shows the situation after scan is seemingly finished.


I'll wait for a new Ubooquity 2 release and go back to version 1.10.

Hi Claus44,


your on a good way, i had the same symptoms befor my 2.x system runs, here my checklist for you : 


- your content path /share/MD0_DATA/... is good, how are the access rights for the user running JAVA 

  (regular its root and 777/rwxrwxrwx , but eventually not?)

- Did you start with a complete >fresh< installation (only the 2.x Ubooquity.jar file in the installation folder) ?


After the above checks, you can do the following step by step : 


- disable [Scan collection at launch],

  disable [Protect shared content with user accounts],
  disable [Do not remove data from unreachable folders] and 

  remove all users accounts and content paths


- save and restart, and after the restart, fresh set the content paths and 

  enable [Protect shared content with user accounts]


- save and restart, and after the restart, set up the users and 

  set the user content permissions (add them to the paths)


- save and restart, and after the restart, start now your first library scan 

- while the scan runs, test it with a user login and you should see the first scanned comics/books ... 


if this will even not work, >keep calm< and start think about an roll-back to Ubooquity 1.x  :( ...


really hope that helps 


best regards 


TierparkToni

Hi TierparkToni,

thank you for your detailed description to "save" the 2.1 installation. That animate me to make a new trial. Tomorrow I have time to process your list.

But I have some questions:

where can I check, that the user running JAVA is root?

in which path should the rights for him set to 777?

What is your QNAP-Firmware? Perhaps it has something to do with it (my version is 4.2.6)?

Do you know how many books Ubooquity can manage totally or in one path? Can it be a problem with the number of content? ...or content in one path?

...and than I have the same problem with correct time like before in version 1. In the original installation is the time 2 hours too late (instead of 14:00 12:00). I fixed it in version 1 and now in version 2.1 with the addition 

"-Duser.timezone=Europe/Berlin"

complete line:

$JAVA -Duser.timezone=Europe/Berlin -Dfile.encoding=UTF8 -jar Ubooquity.jar -webadmin -headless &

Do you think that this can make problems?


Best regards

Claus44


P.S.: I can connect via SSH to my NAS, but I'm not so familiar with Linux



Thanks for detailed explanation TieparkToni.

Spending time to read books is nice as well, but to know where the problem are and to solve them is more fun.

I love to spend time with my Linux system, even if there are problems like this.

Unfortunately are my Linux experience very small and so i´m learning with "try & error".

Never mind with 2.1, 1.10 is working perfekt.

If i will update to Debian 9, i will try 2.x again :-)

Best regards

Kaily

I have made a clean install of Ubooquity 2.1 and set up according to the description of TierparToni. But it is not running. I have the same symptoms like before: After finishing the scan, Ubooquity is not reachable neither as administrator nor as a user. Both sites freeze and there is no action or navigation on the sites possible. After closing the sites and try to open they are not reachable.

I'am back on 1.10.1 and it works fine.

it's a pity, especially because the new administration is very tidy and logical, but I'm waiting for new releases.


Thanks to all for help.

Claus44

Hi Claus44,


my QNAP TS453mini works with QNAP 4.3.3, and the difference between yours and mine are the 32/64 bit Linux kernel - your Fujitsu-QNAP works with an 32bit OS and my TS453 works with an 64bit OS (and 64bit-Java, too) ...

Which Version of Java do you use on your NAS ? Delivered by Original Qnap-App-Store or via (inofficial) QnapClub-Store (http://store.qnapclub.eu/store.php) ? Or completly different via manual installation ? 


Maybe here is the next problem found ? My Ubooquity 2.x runs perfect with 64bit Java, but it was massive buggy before with the old 32bit Java - on my QNAPs (here is an old HS210 ARM-device, too) ...

On my VM-Debian servers it works perfect with no matter of 32/64bit Java.


To your other questions : Ubooquity has no official limit with the amount of books/files, no matter with all in one path or at different local locations - but it needs some RAM (2 GB min) for scanning the files and add them into his own database - 

my QNAP runs with 16 GB RAM, so my Java has (running an other app,too) global 4GB to allocate ... 

My Ubooquity runs currently with ca. 14.000 comics, 8.000 epubs - and ca. 140.000 (!) PDFs (technical car manuals for BMW and VW) and uses 700 of 3500 MB RAM. 

 

 

Best Regards 


TierparkToni