0
Planned

404 NOT FOUND

Skyler Jermyn 2 years ago updated by Tom 2 years ago 4

I'm having an issue where Ubooquity's front end search tool is generating folder results with each one of those results leading to a 404 page. The front end option "flat view" has to be in effect for this error to appear. A 404 page will no longer 404 when "folder view" is back in effect. The backend option "bypass single root folder" appears to have something to do with it as this error is only observed when that option is set to FALSE. Each of these 404ing folder results have a corresponding book result that works fine, but the two look very similar similar so it's easy to forget and end up at a 404.

I have this running on a synology. Calibre generated the folder structure in my book directory, with every author owning a separate folder. I've tried restarting my server, restarting the unbooquity process, rescanning my library, and "clearing book database" and rebuilding my book database.


A sample error is:

HTTP ERROR 404

Problem accessing /books/1369/. Reason:

    File not found


Let me know if I should provide any more information and thank you for developing this software!

Under review

Thnaks for the accurate probelm description. But the only way I managed to reproduce your issue is by:


  • Being in "folder" mode
  • Doing a search that returns folders
  • In another tab, switching to "flat" mode
  • Clicking on a folder in the first tab

In the scenario I described you get an error because Ubooquity is not supposed to display folders in "flat" mode. (settings are stored in cookies, so when you change them in one tab, all others tabs are affected)


But I guess this scenario is not what you did. If you could describe an exact sequence of event that lead you to the issue, I could try to reproduce on my side.


Hi Tom, thanks for getting back. Here's how I just tested with both Chrome and Safari:

1) Close all tabs and browser instances except for one.

2) Delete cookies related to my Synology/Ubooquity domain.

3) Restart the browser.

4) Go to my Ubooquity domain and then to the book section. "Folder view" appears to be the default.

5) Search for a random keyword. Pick a folder result. It works!

6) Press the "Up" button twice to return back to the home page for the book section.

7) Switch to "flat view."

8) Repeat step 5, except that it doesn't work. I get a 404.


Unfortunately these results don't appear to match what you are seeing. For me though, when I am in flat view, I always see folder results in search and those results always return 404. I'll report back if i find a use case where that doesn't happen for me, or if I find anything else out that could be a clue.

Another note, for this test I tried "bypass single root folder" with both true and false set with no difference. So at this point I'm not sure how that setting relates, if at all. 

Your scenario allowed me to consistently reproduce the issue (and apparently it only affects books, not comics).

There is definitely something wrong with the display settings, but now I should be able to write a fix. Thanks for the help !