0

OPDS Error 500

MegaCookie 2 years ago updated by Brain Node 2 years ago 2

When I enable ubooquity opds and access the OPDS page I get an Error 500. This is on a Linux server with Oracle Java and I get the same result with openJDK. I also use a Nginx reverse-proxy with the following prefix: 'ubooquity'. Accessing the normal Ubooquity interface works fine.


Edit: I also tried: /ubooquity/opds-comics/ with a slash at the end, but that didn't solve the problem.


In the logs I see:

20180427 14:47:10 [qtp1420232606-93] ERROR com.ubooquity.d.b - Request processing failed for URI: /ubooquity/opds-comics (method:GET)
java.lang.IllegalArgumentException: Illegal base64 character 2f
at java.util.Base64$Decoder.decode0(Base64.java:714) ~[na:1.8.0_162]
at java.util.Base64$Decoder.decode(Base64.java:526) ~[na:1.8.0_162]
at com.ubooquity.f.k.a(SourceFile:17) ~[Ubooquity.jar:2.1.1]
at com.ubooquity.d.c.a(SourceFile:153) ~[Ubooquity.jar:2.1.1]
at com.ubooquity.d.c.a(SourceFile:107) ~[Ubooquity.jar:2.1.1]
at com.ubooquity.d.b.handle(SourceFile:54) ~[Ubooquity.jar:2.1.1]


And this is the HTML response:

HTTP ERROR 500

Problem accessing /ubooquity/opds-comics. Reason:

    Internal server error: Illegal base64 character 2f

I  figured it out:

When using the option `Security > Protect shared content with user accounts`, the opds gives an Error 500 even when authenticating with the right user/pass.

Without setting that option, everything is working.

Also reproduced on a Windows system.

I has the same problem, but for books catalog.

And it happened suddenly, i mean i try to open one books,opds under security was working, but book couldn't be opened. After that my opds catalog brokes on all devices.

Comics catalog still working good.

I tryied to clear books database, but still has problem.

Books were with russian names,in .fb2 extension.

Also, i updated version from 2.1.1 to 2.1.2 and still have the problem

UPD. I remove opds catalog from my mobile app and add again, problem dissapeared. Interesting, that error also shows on ubooquity service.

Another that i mentioned, when i try to get books except pdf & epub, i get error 401(fb2,awz,djvu). Today i try figure out, what request Moon Reader send to server and why it happens.