0
Answered

Ubooquity outside locak network setup

Scott Richards 5 years ago updated by Tom 5 years ago 5
trying to install on a computer hard wire connected to a DIR-655 linksys router. I have set the port forward and publick ip adress in the port forwarding rules to no avail.

local address = http://192.168.0.101:2202 (works fine)

public address = http://68.83.195.194:2202

Any help would be greatly appreciated!
Under review
Perhaps you have a firewall on the computer running Ubooquity (Windows has one by default).

On my setup I had to open/forward ports on the DSL modem, the router, and the Windows firewall.
My modem is a motorola surfboard and to my knowledge  has no config options. I tried adding a port to the windows firewall but it is not clear exactly how to do that. I add a new inbund rule and that's where it gets unclear. You can not add ubooquity because it's a jar file. So the next logical conclusion is try port.

When i add port I have the option to choose TCP or UDP and then under specific local ports I add "2202". Thing is can only choose TCP or UDP. I have tried both and it still doesn't work.

I guess one of the first things i don't understand is why is the public address out of local LAN subnet? I also run plex and am able to stream from outside of the network but it has a ip address within the subnet range.
DIR-655 is D-Link router not Linksys.  Under Firewall Settings/Advanced, check the DMZ button and input the IP of the machine running Ubooquity. If Ubooquity now works then you have configured port fowarding wrong. If it still doesn't work try disabling Windows Firewall.
Public IP is issued by your ISP which you have no control over (unless you purchase a static one). LAN IPs are assigned by your router in the range 192.0.0.0/10.0.0.0
The problem is you have to allow Java though your Windows firewall. Add an exception rule to your Java JRE