0
Under review

Downloading Semi-Working

Scott Townsend 5 months ago • updated by orshak 2 days ago 7

Wondering if anyone else has run into this.  I'm pretty sure its a weird Chrome quirk, as Firefox doesn't have the same results.  Also I'm running the latest Stable build 2.1.1.

(In Chrome)When you use the Comic side of the application and click to download, Chrome tries to display the cbr/cbz file.  If I right click > save link as, it will actually download the cbr/cbz.  I tested on the Ebook side and don't get this result, I can download the epub.  


(In Firefox)Click to download and it will prompt for download location for both Comics and Ebooks.

Anyone else run into this and if so, do you find a solution/workaround?

Hello Scott,

shure that you not using any comic reader chrome extension (or pc software with browser support) ? 

i've tested the download function it on 3 computers and can't replay your "cbr/cbz-effect" . 

But, if any cbr/cbz-extension for chrome ist installed, it will open it in a new tab....

Hope that helps !


best regards


TierParkToni

Hey,

I've tried it across four different systems (win10 pro box, ubuntu 17.1, win7 pro, and Pixel 2)  on different networks.  I made sure there wasn't any extensions associated with cbz/cbr reading.  Even made sure and turned off all extensions and made sure on the windows boxes that there isn't anything associated with .cbr/cbz files.  What theme are you using?  Just had a brainstorm that maybe something with the materialized theme I'm using.  I'll switch themes and see if that makes a difference. (edit:  Changed to default theme and still didnt make a difference)

Under review

I have not been able to reproduce the issue either (tested with latest Chrome, 70.0.3538.102, on Win 10).


The only thing I can think of is a proxy that would mess with the HTTP headers.
But that's weird.

Tom,

Yeah I'm running it on nginx with reverse proxy.  Now that you've said that, it might be something in my config.  The download function was working previously, one of my users just told me that they couldn't download about a month ago.  I'll have to check and see if nginx made any changes and look over my config.  

Thanks for testing it your end and giving me an idea of where to look.  Also thanks for making such a great application!

In my case, removing the following header, solved this issue for me:

add_header X-Content-Type-Options nosniff;

I'll see if that makes a difference. I'm currently in the middle of a server upgrade and I'm moving to docker and traefik on the new box. 

It kind of look like the problem i had when using Comyxology v2 theme before the author fixed it.
Might be on related to browser or on theme. 

(no idea if you are using one).



Migrating to Docker+Traefik too ? Good luck with that it can take quite some time in the end, as much as getting the "basics" done with Docker, making it more "permanent", organized AND working with Traefik/reverse proxy and Let's Encrypt/Certs is yet another monster altogether. xD


I hope you'll get there quicker/faster than me (even if it's teaching me/forcing me to learn a LOT of things to do it right xD).