+1

Ubooquity Docker,UnRAID,LetsEncrypt-NGNIX, DuckDNS reverse proxy set up (very close)

iPatrickH 1 month ago • updated 4 weeks ago 3

After following limited guides on youtube and google'ing this issue. I almost have this working. The reverse proxy setup with LetsEncrypt on my mysubdomain.duckdns.org works for tautulli. I am able to got to https://mysubdomain.duckdns.org/tautulli and I am happy with that. If I switch the network type to br0 , as I had originally done. I get 502 Bad Gateway.

The problem is as soon as I change the network to "proxynet", port :443 is assigned to elibrary (ubooquity) which is causing a conflict with LetsEncrypt:443. and I get 502 Bad Gateway when going to  https://mysubdomain.duckdns.org/ubooquity
Alternatively
I can go to https://mysubdomain.duckdns.org:9999/ubooquity and get to my ubooquity site. The Juniper SRX Enterprise gateway is doing its thing with Destination NAT port forwarding. 

I just need to figure out how to assign a different virtual port preferably 2202 to this docker network create proxynet to get ubooquity to work just like tautuilli using port 8181

As far as the admin API, it totally missing unless I change the network back to br0,host. bridge. and I am too conflicted to care because I can workaround this with little annoyances. 

So if anyone has any Ideas, Fill this post up. Thanks. 



I made a config file that I copied the basics to form another proxy-conf and named it ubooquity.subfolder.conf file in \\unraid\appdata\letsencrypt\nginx\proxy-confs



# ubooquity

location /ubooquity {
    return 301 $scheme://$host/ubooquity/;
}
location ^~ /ubooquity/ {
    # enable the next two lines for http auth
    #auth_basic "Restricted";
    #auth_basic_user_file /config/nginx/.htpasswd;

    # enable the next two lines for ldap auth, also customize and enable ldap.conf in the default conf
    #auth_request /auth;
    #error_page 401 =200 /login;

    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_ubooquity Ubooquity;
    rewrite /ubooquity(.*) $1 break;
    proxy_pass https://$upstream_ubooquity/elibrary/;
}


I am getting extremely close to figuring this out and it works. now for some fine tuning. I think I was using a forked version of the linuxserver/ubooquity from hurricane which is nowhere to be found anymore. how this was still pulling from the repositories. I have no idea. 

so I added https://github.com/linuxserver/docker-ubooquity to the Template repositories:and saved.
I re-added the Docker from scratch. I also backed up my themes and keystore.jks files. 

And I now have a working proxynet version, This is what I wanted.


However I still got "502 bad gateway" =(

I went back to my ubooquity.subfolder.conf file in \\unraid\appdata\letsencrypt\nginx\proxy-confs and after a few tweaks I got something that resembles "Hello World" , 



# ubooquity

location ^~ /ubooquity {
    # enable the next two lines for http auth
    #auth_basic "Restricted";
    #auth_basic_user_file /config/nginx/.htpasswd;

    # enable the next two lines for ldap auth, also customize and enable ldap.conf in the default conf
    #auth_request /auth;
    #error_page 401 =200 /login;

    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_ubooquity ubooquity;
    proxy_pass http://$upstream_ubooquity:2202;
}


Oooo that's progress.. 

That's it: just 6 lines in the ubooquity.subfolder.conf file in \\unraid\appdata\letsencrypt\nginx\proxy-confs
Very Happy to get this working.  found the answer somewhere in this forum.



# ubooquity

location /ubooquity/ {
    proxy_pass http://Unraid.HOST.IP:2202/ubooquity/;
    proxy_set_header Host $host;
}