0

Odps not working

Tomtom602 8 months ago • updated by Sparky 5 months ago 2

Hello,

I've just installed ubooquity 2.1.2 on my freenas. 

It works fine using the web browser. 

I then tried to use the android app with odps. (ku boo) 

And it's not working. I tried to access the odps page through browser to see if I have a valid xml, but I only see the default page of ubooquity. 

Odps is activate on admin page. 

Does anybody have an idea how to make this work? 

I have figured out my first problem I was trying to get the page /odps-comics/ (wrong page) this was /opds-comics/

there I can see the xml


I've figured out that, if I use my IP adress in place of my domain name, ODPS is working fine and the APP can retreive my comics.

so the problem comes from my Nginx reverse proxy !

Does anybody have a valid reverse proxy configuration, that he could share with me ?

here is mine :

server {

  liste 443 ssl;

  server_name comics.mydomain.com;

  

  ssl_certificate /pathtossl

  ssl_certificate_key /pahttocertificatekey

add_header Strict-Transport-Security "max-age=31536000";

  location / {

    proxy_pass http://192.168.0.5:2202/;

    proxy_set_header Host $http_host;

    proxy_set_header X-Real-IP $remote_addre;

    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

    proxy_set_header  X-Scheme $scheme;

    proxy_read_timeout 1800;

proxy_connect_timeout 1800;

    proxy_request_buffering off

  }

}

i dont have a valid config but I can tell you that you need listen and not liste on line 2