0

Problem of missing/wrong cover in Ubooquity

orshak 4 months ago • updated by DarkShadowSwE 4 months ago 1

Recently, since i moved Ubooquity to Docker (or so i thought), i've been encoutering a weird problem :

quite often, i've got some covers not showing (it's the "broken image" icon showing up in the bottom left corner), or worse, wrong covers showing up on some books/folders (and bet it, amongst the 3k+ files in my comics folder(s) and the 4k+ in my books folder(s) it seems to always be the under 10 comics and under 50 books that are leaning toward erotic/sex Images/Covers, Go figur :D).

When i reload the page, with or without clearing cache (F5 or Ctrl+F5), it doesn't solve it, because in the end, the ones that weren't displaying an image/cover or an incorrect  now do... but others that displayed one (the proper one) don't anymore....

When i click on a book, it shows the proper cover image and metadata.

I was wondering if it was a problem of memory allocated since it runs in a docker and is limited to 512Mo Ram by default (i didn't change that settings), and i tried too, to wipe the database and redo a complete and new scan.

Both things failed in the end.

But the thing is i installed Ubooquity on another computer a couple days ago (for a friend, so they would have a way to see/search things more easily than using the windows explorer for the books i gave them, but without resorting to being forced to use Calibre and the dumb ass "hey you MUST store your books the way I decided you must store them" system... :()... and it ended exactly the same.

Any idea where it can come from ?

I'm using the Comixology Theme (latest version) on both installs, but i've tried without it and it's the same.

So the cover didnt work for Calobre either?