0

Ubooquity 2.1.2 in Docker/portainer (raspberry pi) will not let me change portnumbers for library

Michiel Niemeijer 1 month ago updated 1 month ago 0

Hi all,

I have this problem where I just cannot get Ubooquity to work with another portnumber than 2202 (for library access). My setup is as follows:

- raspberry pi 3b+ (Raspberry PI OS)

- OMV5 with Docker/Portainer ( linuxserver/ubooquity:latest)

- Multiple containers running, several with custom functioning 'published ports' (what I would call port forwarding between dockerhost and container)

- Configured Macvlan to enable dockercontainers to have their unique/own IP within my LAN (like for example Pihole, successfully running and working on its own local IP)


Issue: I want ubooquity to work on webport 80 instead of 2202, so I can assign a local domain name and have the users not needing to remember IP numbers. No matter what I try to do:

* in Docker container 'Manual network port publishing' settings configure 80 --> 2202 mapping

* edit 'preferences.json' file value "libraryPortNumber" : 80

it does not work. Seems like Ubooquity totally ignores these values? Or when I restart my container the values are reset. Quite frustrating as this is the final piece of the puzzle I need to solve before 'going to production'. 

Any suggestions? Thanks so much in advance for your assistance,

Kind regards,