0

Ubuntu Mate 18.04

dragon13 5 months ago • updated by Think Strategy 5 months ago 1

Can't access admin interface. Tried using another computer. Running ubooquity on NAS, NAS firewall is forwarded for used port. Tried IP:port/admin also tried IP:port/ubooquity/admin , nothing works. Performed a restart. I can pull standard Ubooquity web interface but not admin. Tried changing port number using preferences.json also made sure remote admin option is enabled. I've been working on this for two days now, No Go! Thank you.

This is my startup-script

[Unit]

Description=Ubooquity

After=network.target

[Service]

User=<USERNAME>

WorkingDirectory=/opt/ubooquity

ExecStart=/usr/bin/java -jar Ubooquity.jar --headless --libraryport <PORT> --remoteadmin --adminport <PORT>

[Install]

WantedBy=multi-user.target

To test if it does work try it this way

/usr/bin/java -jar Ubooquity.jar --workdir /opt/ubooquity --headless --libraryport <PORT> --remoteadmin --adminport <PORT>

Remember, you need java or the opensource alternative JDK. The library port cannot be the same as adminport. To access your administration page from another computer, --remoteadmin needs to be also included. To access administrator page go to

<IPADRES PC>:<adminport>/administrator


Also have your ubooquity.jar with the next permissions 

 

sudo chmod a+x Ubooquity.jar