Synology DSM 7 removed Java - how I started Ubooquity

jantloust 3 years ago updated by De Cessandre René 2 years ago 5

As it look like there will be removed easy support for Java in DSM 7 (or at least it is removed in version 7.0-41882) and Ubooquity need it to be able to run I been looking if someone in Synology user community created replacement Java package.

And fortunately there is Rednoah's Java Installer.

It can be accessed on this URL https://github.com/rednoah/java-installerwhere is short description how to add it as package source in Package Center.

Unfortunately on mine DS2413+ installation from there failed but I haven't given up and downloaded most current version of spk package to computer and then uploaded it in Package center as Manual Installation. That have been successful and after some time installer reported Java installed.

I downloaded spk from https://github.com/rednoah/java-installer/releases/download/2.16/java-installer_2.16-dsm7.spk (but this URL will be most likely obsolete soon and it might be better to find most up to date url in syno-dsm7.json file on Rednoah's GitHub)

And I just had to replace path to java binaries in conf file (if used) from


to path where java-installer downloaded new java


and mine home Ubooquity service is back on

Perhaps consider using a docker image liike linuxserver/ubooquity:latest for a really effortless installation and maintenance...

Do you have a tuto on how to use docker with synology DSM7? 

because I've just tried this solution and couldn't get it to work (after years of using ubooquity, I'm not happy)

OK! I managed to get ubooquity running again using the linuxservierio docker image... I had to scratch my head a little to get it working though, and I'm not quite satisfied as I only got it running as superuser for which I'm not happy: I wanted to get it to work as ubooquity user which I created for that purpose... 

I might put a tuto if I get it to work properly

Please take a closer look at the PGID and PUID variables of the linuxserverio image (refer to "User / Group Identifiers" in the
instructions). You want these to reflect your syno's dockeruser IDs to avoid using su rights. You can get them via SSH. For my DS its PUID 1031 and PGID 100.

Thank you, jantloust ! Your solution worked for me. My Synology NAS does not support Docker (DS218) and I was thinking I couldn't use Ubooquity anymore after DSM 7.0 installation. You saved my life ! ;)