Under review

Kuboo - Ubooquity Client for Android

Seth Chhim 4 years ago updated 2 years ago 62

Hello, I'm back with a refactor of my Android work. I decided to rebrand (Kotlin + Ubooquity = Kuboo). This time the project is a more modular build and also fully open sourced available on Github. I am getting more comfortable with Kotlin and I hope it shows here with many performance improvements and bug fixes.

Give it a try if you would like! Post any bugs or requests on Github Issues, not this thread please.



Under review

Very nice !

I've started working with Kotlin too (on backend applications though, not on Android) and I plan to gradually convert Ubooquity to it.

How I configure the server? I added the and nothing appears in browse tab  :/

1. Enable the OPDS feed in the Ubooquity server's administration settings.

2. Use the address or , depending on which one you want to access. 2202 is the default port, change it accordingly.

Nop, i have setted everything as you say: "", without the "", and the app says  "folder is empty!" :(

Here are some steps for you to troubleshoot, pardon me if you have already done these steps.

1. Enable OPDS feed in Ubooquity and save settings, it should look like this:

2. Try your "" url in any web browser it should pull up the OPDS feed (XML) and look like this:

If the opds feed is missing from the browser, it is a server issue. It it shows in your browser but missing in the app, it is a client issue. Let us know what problem you have.

The feed (XML) appears in my browser but not in the app :/

1. Can you please confirm you wrote the server address in the IP Address box and not Server Name box

2. Looks like a local address, is the device connected to the same network.

Yes, i have the ip address in the ip address box hehe :) In server Name i put  "PC". I wrote wrong the ip adres, it ends in 101, not 100, but not works anyway.. Same problem..

My PC with the server is conected via LAN cable (UTP) to my router, and my cellphone connects to the same router, but in wifi, or WLAN.. Can be this the cause of my problem? :P

Your network setup sounds fine. Try the server url in a web browser of the mobile device, not your server pc. I suspect maybe the port is blocked by a firewall or router.

Indeed, i cant access from the web browser on my android phone.. Maybe i should take a look on my router config to open the port 2202?

Yes sounds like that is it. Open ports in your operating system firewall and on your router, forward the port to your server.

great work!  love the download feature. presume we must manually clean this up as necessary
Don't understand the tracking/ interval part...?

Note: a download is considered in the same series if it is in the same folder.

Download tracking will download the next items in the series automatically so they will be available offline. It will also delete the finished download for you. The limit of download per series can be set in settings.

Here is an example, say you downloaded Book #4 of series. When you enable download tracking and the limit is set to 3, Books # 5, 6, and 7 will be downloaded. When you finish Book #4, it will be deleted and Book #8 will  be queued. This tracking will keep your downloads up to date with your reading progress.

There are multiple triggers to start your tracking queue including a timed interval. Hopefully the queue will start up once your connection comes back up if it was once unavailable.

Hope this makes sense, still a work in progress but the main functionality is there.

Are there plans for more options when browsing the collection? Right now it is really cluttered as it only has space for about 3 letters before starting a new line.  It's really hard to understand what I am looking at with 2 columns that can't list the entire title without wrapping around.

I also notice it doesn't generate the thumbnail on alot of the folders.

I forwarded your message to the issue tracker. Thanks for the feedback, I will look into it and respond there.

This is what my library looks like.

The no thumbnail appears to be an issue with sub-directories. All of the folders that have no subdirectories show thumbnails fine. If there are subfolders, no thumbnail.

Thanks this is useful, I am looking into it.

If I disable the option for "Favorite", the star will go away and the listing looks better. The star is really shoving all of the text aside. The Favorites option is on by default so this is why it was so alarming at first glance.

I see resolution is 2560x1440 but can you post how big the screen size (inches) is so I can mock it in emulator.

It's 5.5 inches I believe. Samsung Galaxy S7 Edge.

Wow. Nice!


I just updated the app. It looks much better. Didn't realize that it wasn't supposed to be 2 rows.

Still not generating thumbnails on a lot of folders

Thumbnails only show if the directory contains media directly, not its subfolders. This is a limitation of the server's opds feed. I don't want to make the app fire multiple chains of network requests and crawl multiple subdirectories to find a thumbnail as it will affect performance. This would be a great feature request for Ubooquity.

hi great app.

Just wanted to know if theres a way to list comics in file order as some of my issues are all over the place 


Spider-Man 001 

Spider-Man 002

Spider-man 003

Spider-Man 101

Spider-man 102

Spider-Man  004


I forwarded your message to the issue tracker. Thanks for the feedback, I will look into it and respond there.

Great job!!!!

I suppose that you will be introduce new features in the future. Do you have a list of them?

Thanks for your effort.

I do not have a roadmap but I this has been a passion project of mine for quite a while now. You can follow development or post issues on github. Thanks for trying out the app.

Okay so I'm having issues with certain files showing up in the app.  I have a mix of .cbr and .cbz files and almost all of them work, except a handful that don't for some reason.  I have been using the app Perfect Viewer and it will load ALL of my files without issue, over LAN.  What I would love to do is to be able to stream all of my 300+gb collection without having to download them to my tablet.  Is there any way to use a Ubooquity server with the Perfect Viewer app? PV supports opds, and that's how I was able to set up the Kuboo app, but I am unable to replicate it in PV.  My biggest problem is that the main series I want to read, Uncanny X-Men, won't even load the cover page for the comics, unless I download them.  Again, the other files in the folders are the same file type, .cbr/.cbz, so it isn't an issue with my files.  ANY help on this would be greatly appreciated!  Thank you for all of your hard work on all of this app!

I am not the author of Perfect Viewer so I can't provide any support there. If you are having an issue with loading a certain book in Kuboo, I can definitely help. Here are some things you can try:

1. Does the book load in Ubooquity's web browser reader? I would like to know if the Ubooquity server can process the file or is it the client app that fails.

2. Email me the book file that doesn't load and I will test it out sethchhim@gmail.com


any plans at all for an iOS version?

No, I have no experience with iOS. I will recommend Chunky Reader, it is top notch.

Hey Seth, really liking the application and the work you are doing. Firstly, is there anyway I can support your work. Will a "Pro" version be available on completion? Currently have I have it running on my old ASUS TF201.  Download tracking is also brilliant. Just a quick question - is it possible to change the download folder. I seem to only be able to select internal or external storage. Have I missed something. Regards Kev

Forwarded your message to the issue tracker for archival purposes, I will reply there thanks! https://github.com/sethchhim/Kuboo/issues/22

I can't get Kuboo to detect my server at all. I did all the steps mentioned above and I get the XML in the browser and the same ip works perfectly on Challenger Viewer, so I'm pretty sure it's a Kuboo issue. Does the application have any logs I could look at to maybe try to troubleshoot what's going on?

Can you please try to add "http://" or "https://" to the beginning, depending on if it is secured or not.


I can't believe I didn't think of that. Thanks! It's working now.  

There's an option to download comics from the server (I assume for offline viewing), but I can only access them from the download window. Can they be accessed from the home and browse screens as well?

It is setup like this because Home and Browse screens require internet connection and Download screen does not. If you have any comments or feedback please post at https://github.com/sethchhim/Kuboo/issues/ for archival purposes. Thanks for checking out my app.

Hi Seth. Thanks for the reply. I will attempt example when I get home from work. Have a good day. Kev

Hi Seth, 

I'm having an issue where Kuboo connects to my server but does not show any comics. I can access the server fine through ubooquitys web client, and the error message is different to when kuboo can't connect to the server (where it says server not available) -- in this case it says start reading to add items under the recent comics heading. When I choose more, I get a 'folder is empty' message. 

Any ideas? 

Hi Seth,

Many, many thanks for the great app. I used the previous incarnation and love the app. Clean, simple, easy to use. It does what it says on the tin!

I had been using it internally for a long time and my son wanted to use it remotely. I run my Ubooquity server on unRAID and setup a reverse proxy for ubooquity using duckdns. I was struggling to get it to work until I opened up port 2202 on my router. 

Now works perfectly. Just posting for others. The other thing, as posted above it to use your web browser to test and debug when setting up. I found this very helpful. 

Thanks again for the great app!

Hum it's really a great app honestly, and the performance compared to others is quite impressive honestly.

It's fast as Hell. ;)

Purely interested question, would you be motivated enough to expand it to ebooks/pdf reader, because honestly it blows out of the water most of the competition in that domain, and i would love being able to use your work as an opds ebook reader too. xD

(i have even more books than comics on my Ubooquity Server and i tend to read them more on public transport/on the move than comics, that i mostly read on my Android Devices at home xD).

Epub and pdf are already supported. The epub reader is based on epublibDroid and the pdf reader is based on the internal comic reader.

You need to setup your server and possibly use the path "/opds-books/". All servers are different but it should be able to see your .epub and .pdf files.

This project is no longer in active development because I'm working on different projects. Thanks for checking out my app, there was a big need for a decent user client and I hope this fills it.

Just wanted to say thanks for the fantastic job you did on this client app!  I only wish there was an iOS version (but I know what a pain it can be producing iOS apps and putting them on the App Store).

Rooh stupid me i didn't even notice that, i was certain it was "comic books only" so i didn't even try it. :/

Sorry for that and thx for the quick answer. :)

Seth, I know this is archived now, but I would like to submit a PR:


The URL format is changed on the latest version of ubooquity, and I think this would be a good fix to avoid confusing users.

New format is:


Old format:


I know this is no longer supported, however, Kuboo stopped working for me 2 weeks ago.  I did what MWK suggested (ip-addr:2202/ubooquity/opds-comics/) and I can'f figure what's wrong.  I called my ISP and they said everything is peachy on their end.  I can access my Ubooquity server via my server host computer, but I can't access it via ubooquity on my chromebook, despite having used it for a couple of years without issue.  Anyone have any ideas?  I am really missing my comics!  Thanks in advance.


Can you reach your server from any other machine aside from the server?  If you can hit it from your local network but not external (say on your cell phone or outside your home network) then check your router firewall exceptions.  You may also want to check your server firewall settings.  Log into your server and try testing port 2202 using either site:



If your server is a windows box, I know a recent windows update appeared to have changed my network from Private to Public somehow, which changed a lot of my network settings.

Just found ubooquity and Kuboo, and it is great. There are a few small things I would like to fix, and have fixed, and was wondering if there was anybody interested in an collaboration?

@seth Great job on the app, and for making it open source.

Really handy app, can anyone advise on an odd issue I am having.  Whenever I am reading a comic, I cannot exit back to the home screen.  I have to completely force close the app, then reopen it again.  Is this a know thing to workaround, or am I missing something?

Thanks again for a great app

Try swiping up from the bottom of the screen, I think it is called immersive mode. Your system ui should show up again.

@Seth The app is really good. Can you support the webtoon mode reader?  It should be vertical scroll continuous. Tachiyomi has webtoon mode, but it doesn't support Ubooquity. I want this feature because many webtoon comics have really big image in height. It's really inconvenient to read comic now when I have to zoom in the image then scroll down to read the whole image.

The app is archived and will no longer be supported with new releases. It was just a (good) learning experience for me.

How can I have it so it shows books and comics at the same time?  If I need to enter -comics etc?
Or am I missing something?


This is how the ubooquity api is made, I have zero control over this.

Ubooquity is great- thanks so much, Seth!  I use to read comics daily and it makes my life better.  So, again, thank you for your efforts and thank you for still paying attention to the questions section of an archived app!


Thanks for this app, it's a really good job.

I've got 3 suggestions :

1) It could be nice to be able to add "local directories" in addition to the ubooquity server

2) In the browse section, folders are only displayed with little thumbnails. Is there a way to display them with big thumbnails, as it's done with comics thumbnails ?

3) In the home section, it coud be nice to be able to add favorites folders


First of all, nice Day of The Tentacle avatar.  I loved that game.

Second of all, this app is no longer updated or monitored.  It's all open code so you are free to make a fork of it and start a version of it!

Thanks for the answers.

Oh, too bad it's not longed updated.

Unfortunately, I don't have the technical skills to make a fork. I will use it as is.

First, I want to say GREAT PRODUCT! I've been using it for about a year to read my comics on the go. It's worked great, and I have no real problems with it.

I have, though, been working on making my server more cosmetically appealing, and been adding folder metadata. However, I can't seem to find a way for this metadata to show up in Kuboo. Is it possible? It's a minor issue, and only cosmetic, so not a "deal breaker" fro me. Just a little added touch I would like to include for those that access my server (my kids and a couple friends only).

I was able to get Kuboo connected to my Ubooquity server and it worked perfectly, but then the next day, it still seems to be connected, but has a message on the screen that says "Start reading to add items!" and does not show anything from the server.

Server is still running on the host PC, and I can view all items from the host PC.  Any ideas?  Thanks for the app and any help!

Note, I get that error on my android phone in Kuboo.  When accessing my library on my server PC, I have no issues.  

The local database may have been corrupted. There is probably no way to recover that data.

If it was working before try to 'Clear Data' in the app settings to start over with a fresh database.

Sorry for the limited solution, I have dropped support because I do not think the Ubooquity project is active anymore. Good luck, hope you can fix it.